core: add "cmake3" to the list of cmake candidates
authorCarlos Santos <casantos@datacom.ind.br>
Sun, 7 May 2017 04:32:21 +0000 (01:32 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 24 Jun 2017 19:26:20 +0000 (21:26 +0200)
This is useful on CentOS 7, whose "cmake" utility corresponds to version
2.8.12, which is too old for Buildroot.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
support/dependencies/check-host-cmake.mk

index ef080ff7c6ed392d5945c12336416430b1bb4acc..07b064c9fdf43601badadb7aac19e4871d25697f 100644 (file)
@@ -10,7 +10,7 @@
 #
 BR2_CMAKE_VERSION_MIN = 3.1
 
-BR2_CMAKE_CANDIDATES ?= cmake
+BR2_CMAKE_CANDIDATES ?= cmake cmake3
 BR2_CMAKE ?= $(call suitable-host-package,cmake,\
        $(BR2_CMAKE_VERSION_MIN) $(BR2_CMAKE_CANDIDATES))
 ifeq ($(BR2_CMAKE),)