glibmm: bump to version 2.46.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 13 Nov 2015 18:05:55 +0000 (15:05 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 14 Nov 2015 08:39:48 +0000 (09:39 +0100)
Adjust pulseview/libsigrok for the gcc >= 4.8 dependency.

Line wrap comment depends for pulseview.

Drop redundant libsigrok depend on comment for libsigrok++.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/glibmm/Config.in
package/glibmm/glibmm.hash
package/glibmm/glibmm.mk
package/libsigrok/Config.in
package/pulseview/Config.in

index 6ac4be543235878bae7af9d32c53c586b8de53c7..fdbb43812c9c63b32496d878252dcde318e6c483 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_GLIBMM
        bool "glibmm"
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBSIGC
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
@@ -11,7 +12,7 @@ config BR2_PACKAGE_GLIBMM
 
          http://www.gtkmm.org/
 
-comment "glibmm needs a toolchain w/ C++, wchar, threads"
+comment "glibmm needs a toolchain w/ C++, wchar, threads, gcc >= 4.8"
        depends on BR2_USE_MMU
-       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
-               !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || !BR2_USE_WCHAR \
+               || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
index 4fbde55a3542779a37bc2d2a82a1a214e8cc2bc9..9a7a6c889a4efc9ec30c06d412fa9c594caab0a0 100644 (file)
@@ -1,2 +1,2 @@
-# From http://ftp.gnome.org/pub/gnome/sources/glibmm/2.36/glibmm-2.36.1.sha256sum
-sha256 d1f7dec2fd75ea95034ec143fcf2ff77a02e92aacf3e0cc110f9c67e7fe23766        glibmm-2.36.1.tar.xz
+# From http://ftp.gnome.org/pub/gnome/sources/glibmm/2.46/glibmm-2.46.1.sha256sum
+sha256 9647e596c1081d2ea202bd3da2824ec2ea359498fa86eb59a55b1b307dd8c4aa        glibmm-2.46.1.tar.xz
index 4081251da09fd21296b96cec0c927dffe9fa4ce3..66b357d400cdb9e5b22038aca26d8c8e0d264771 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-GLIBMM_VERSION_MAJOR = 2.36
+GLIBMM_VERSION_MAJOR = 2.46
 GLIBMM_VERSION = $(GLIBMM_VERSION_MAJOR).1
 GLIBMM_LICENSE = LGPLv2.1+ (library), GPLv2+ (tools)
 GLIBMM_LICENSE_FILES = COPYING COPYING.tools
index 6ef37768f6d6168e9e62ee098c76c297a0b99efc..ff2d249827a448dd5886808990a822ccd70b3a33 100644 (file)
@@ -24,12 +24,13 @@ config BR2_PACKAGE_LIBSIGROKCXX
        bool "build C++ bindings"
        select BR2_PACKAGE_GLIBMM
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # glibmm
        help
          Build libsigrok C++ bindings as well.
 
-comment "C++ bindings need a toolchain w/ C++"
-       depends on BR2_PACKAGE_LIBSIGROK
-       depends on !BR2_INSTALL_LIBSTDCPP
+comment "C++ bindings need a toolchain w/ C++, gcc >= 4.8"
+       depends on !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
 
 endif
 
index e6ddc211e45e419576e17154c158c878e1a8bcdb..bbbfd7672eb0397f2f1629a6a2ad4b42777cf30d 100644 (file)
@@ -17,15 +17,16 @@ config BR2_PACKAGE_PULSEVIEW
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_PACKAGE_BOOST_ARCH_SUPPORTS
        # libsigrok
-       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
        help
          PulseView is a Qt based logic analyzer, oscilloscope
          and MSO GUI for sigrok.
 
          http://sigrok.org/wiki/PulseView
 
-comment "pulseview needs a toolchain w/ wchar, threads, C++, gcc >= 4.7"
+comment "pulseview needs a toolchain w/ wchar, threads, C++, gcc >= 4.8"
        depends on BR2_USE_MMU
        depends on BR2_PACKAGE_QT5
        depends on BR2_PACKAGE_BOOST_ARCH_SUPPORTS
-       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
+       depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || !BR2_USE_WCHAR \
+               || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP