samba: explicitly link with -pthread if avahi support is enabled
authorSven Neumann <s.neumann@raumfeld.com>
Mon, 21 Sep 2009 16:48:10 +0000 (18:48 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 21 Sep 2009 19:25:00 +0000 (21:25 +0200)
The avahi-client library makes use of threads. We need to link the
smbd binary with -pthread if avahi support is enabled. Otherwise the
binary will crash at startup.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/samba/samba.mk

index 45e9938cf6dac79d781d87490822795d0a68ebd8..82bf152e23749acda922aad19d2df5a9bc7e5b20 100644 (file)
@@ -36,6 +36,7 @@ $(SAMBA_DIR)/.configured: $(SAMBA_DIR)/.unpacked
                samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
                samba_cv_fpie=no \
                libreplace_cv_HAVE_IPV6=$(if $(BR2_INET_IPV6),yes,no) \
+               AVAHI_LIBS=-pthread \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \