flann: new package
authorDavide Viti <d.viti@infosolution.it>
Tue, 15 Apr 2014 20:50:05 +0000 (22:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Apr 2014 21:14:00 +0000 (23:14 +0200)
[Thomas: changed license from BSD to BSD-3c, to be more specific.]

Signed-off-by: Davide Viti <zinosat@tiscali.it>
CC: minimod@morethan.org
CC: patrickdepinguin@gmail.com
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/flann/Config.in [new file with mode: 0644]
package/flann/flann.mk [new file with mode: 0644]

index 0e214e3d34ff92faba5d47848a443b29f621c006..01c7ae949adc2947af85b4c082a741d1e69aed79 100644 (file)
@@ -773,6 +773,7 @@ source "package/cppcms/Config.in"
 source "package/eigen/Config.in"
 source "package/elfutils/Config.in"
 source "package/fftw/Config.in"
+source "package/flann/Config.in"
 source "package/glibmm/Config.in"
 source "package/gmp/Config.in"
 source "package/gsl/Config.in"
diff --git a/package/flann/Config.in b/package/flann/Config.in
new file mode 100644 (file)
index 0000000..4b0b5a8
--- /dev/null
@@ -0,0 +1,24 @@
+config BR2_PACKAGE_FLANN
+       bool "flann"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         FLANN is a library for performing fast approximate nearest
+         neighbor searches in high dimensional spaces. It contains a
+         collection of algorithms we found to work best for nearest
+         neighbor search and a system for automatically choosing the
+         best algorithm and optimum parameters depending on the
+         dataset.
+
+         http://www.cs.ubc.ca/research/flann/
+
+if BR2_PACKAGE_FLANN
+
+config BR2_PACKAGE_FLANN_EXAMPLES
+       bool "flann examples"
+       help
+         Build and install flann example applications.
+
+endif
+
+comment "flann needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/flann/flann.mk b/package/flann/flann.mk
new file mode 100644 (file)
index 0000000..6f95f19
--- /dev/null
@@ -0,0 +1,23 @@
+###############################################################################
+#
+# flann
+#
+###############################################################################
+
+FLANN_VERSION = d0c04f4d290ebc3aa9411a3322992d298e51f5aa
+FLANN_SITE = $(call github,mariusmuja,flann,$(FLANN_VERSION))
+FLANN_INSTALL_STAGING = YES
+FLANN_LICENSE = BSD-3c
+FLANN_LICENSE_FILES = COPYING
+FLANN_CONF_OPT = \
+       -DCMAKE_BUILD_TYPE=Release \
+       -DBUILD_C_BINDINGS=ON \
+       -DBUILD_PYTHON_BINDINGS=OFF \
+       -DBUILD_MATLAB_BINDINGS=OFF \
+       -DBUILD_EXAMPLES=$(if $(BR2_PACKAGE_FLANN_EXAMPLES),ON,OFF) \
+       -DBUILD_TESTS=OFF \
+       -DBUILD_DOC=OFF \
+       -DUSE_OPENMP=$(if $(BR2_GCC_ENABLE_OPENMP),ON,OFF) \
+       -DPYTHON_EXECUTABLE=OFF
+
+$(eval $(cmake-package))