package/python3: bump version to 3.8.3
authorAdam Duskett <Aduskett@gmail.com>
Sun, 14 Jun 2020 20:23:46 +0000 (13:23 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 18 Jun 2020 20:14:18 +0000 (22:14 +0200)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
23 files changed:
package/python3/0001-Make-the-build-of-pyc-files-conditional.patch
package/python3/0002-Disable-buggy_getaddrinfo-configure-test-when-cross-.patch
package/python3/0003-Add-infrastructure-to-disable-the-build-of-certain-e.patch
package/python3/0013-Add-an-option-to-disable-installation-of-test-module.patch
package/python3/0014-Add-an-option-to-disable-pydoc.patch
package/python3/0015-Add-an-option-to-disable-lib2to3.patch
package/python3/0016-Add-option-to-disable-the-sqlite3-module.patch
package/python3/0017-Add-an-option-to-disable-the-tk-module.patch
package/python3/0018-Add-an-option-to-disable-the-curses-module.patch
package/python3/0019-Add-an-option-to-disable-expat.patch
package/python3/0020-Add-an-option-to-disable-CJK-codecs.patch
package/python3/0021-Add-an-option-to-disable-NIS.patch
package/python3/0022-Add-an-option-to-disable-unicodedata.patch
package/python3/0023-Add-an-option-to-disable-IDLE.patch
package/python3/0024-Add-an-option-to-disable-decimal.patch
package/python3/0025-Add-an-option-to-disable-the-ossaudiodev-module.patch
package/python3/0026-Add-an-option-to-disable-openssl-support.patch
package/python3/0027-Add-an-option-to-disable-the-readline-module.patch
package/python3/0028-Add-options-to-disable-zlib-bzip2-and-xz-modules.patch
package/python3/0031-Add-an-option-to-disable-uuid-module.patch
package/python3/0033-configure.ac-fixup-CC-print-multiarch-output-for-mus.patch
package/python3/python3.hash
package/python3/python3.mk

index 00a6884771ce97f542b59687fc9db457222e5c7d..1010d08d53dac072acbf32d99cf4e29085568f0a 100644 (file)
@@ -38,7 +38,7 @@ diff --git a/configure.ac b/configure.ac
 index a189d42c2c..4690cdba9f 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1085,6 +1085,12 @@ fi
+@@ -1091,6 +1091,12 @@ fi
  
  AC_MSG_CHECKING(LDLIBRARY)
  
index 95db44a4d3085acbd84962c77800e25005c6e5b8..e9e5b32ca26011e5de18d6753163b2ca9b4c95e0 100644 (file)
@@ -13,7 +13,7 @@ diff --git a/configure.ac b/configure.ac
 index 4690cdba9f..ffeec102b7 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4059,7 +4059,7 @@ fi
+@@ -4080,7 +4080,7 @@ fi
  
  AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
  
index 9bdd9b489734ee8fef0ab5ab2177dbfe80663c5e..c4620949bdf72c80139f6633dc3970f40caa450d 100644 (file)
@@ -78,7 +78,7 @@ diff --git a/configure.ac b/configure.ac
 index ffeec102b7..7872b4dfee 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2952,6 +2952,8 @@ LIBS="$withval $LIBS"
+@@ -2958,6 +2958,8 @@ LIBS="$withval $LIBS"
  
  PKG_PROG_PKG_CONFIG
  
index d34a2883ad1751d0a0b10a75749903cba057ed89..675c2c1abf469b2051f6d2416b43115689fc2967 100644 (file)
@@ -95,7 +95,7 @@ diff --git a/configure.ac b/configure.ac
 index 7872b4dfee..b820d18c7c 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3213,6 +3213,11 @@ if test "$posix_threads" = "yes"; then
+@@ -3234,6 +3234,11 @@ if test "$posix_threads" = "yes"; then
        AC_CHECK_FUNCS(pthread_getcpuclockid)
  fi
  
index cdcabc0c117585b349f71fcf078dff67b4495192..a3436e31bf64e540b5ac3748bd4a25ef7ca2aba2 100644 (file)
@@ -54,7 +54,7 @@ diff --git a/configure.ac b/configure.ac
 index b820d18c7c..f53cc86d89 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3213,6 +3213,12 @@ if test "$posix_threads" = "yes"; then
+@@ -3234,6 +3234,12 @@ if test "$posix_threads" = "yes"; then
        AC_CHECK_FUNCS(pthread_getcpuclockid)
  fi
  
index 03064612a052685f6f613b04fd44819c3c092992..1bd1ae511fa2b98dd9a3848a51d30b921c5c4782 100644 (file)
@@ -80,7 +80,7 @@ diff --git a/configure.ac b/configure.ac
 index f53cc86d89..caa8eaf88a 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3225,6 +3225,12 @@ AC_ARG_ENABLE(test-modules,
+@@ -3246,6 +3246,12 @@ AC_ARG_ENABLE(test-modules,
        AS_HELP_STRING([--disable-test-modules], [disable test modules]),
        [ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
  
index 4f5e0dbd8688a8cc274f2cde7aef1373bab422f0..364d1b1ec8e7c542cb95bec4927c56f148662bc2 100644 (file)
@@ -48,7 +48,7 @@ diff --git a/configure.ac b/configure.ac
 index caa8eaf88a..79a8255f44 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3213,6 +3213,15 @@ if test "$posix_threads" = "yes"; then
+@@ -3234,6 +3234,15 @@ if test "$posix_threads" = "yes"; then
        AC_CHECK_FUNCS(pthread_getcpuclockid)
  fi
  
index b248ecd40c80c8aa241573a85f871b9fcd656d26..eb0ad26daa03b6a13bf1a3d482d50fa0b4bf95dc 100644 (file)
@@ -52,7 +52,7 @@ diff --git a/configure.ac b/configure.ac
 index 79a8255f44..b5922451cc 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3222,6 +3222,15 @@ if test "$SQLITE3" = "no" ; then
+@@ -3243,6 +3243,15 @@ if test "$SQLITE3" = "no" ; then
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index d442f7b8077d3cc0903b7022644a5da31f802019..0628669b93deae4e9584bd6a75bd06b230461894 100644 (file)
@@ -41,7 +41,7 @@ diff --git a/configure.ac b/configure.ac
 index b5922451cc..ea422a86a9 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3231,6 +3231,15 @@ if test "$TK" = "no"; then
+@@ -3252,6 +3252,15 @@ if test "$TK" = "no"; then
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
  fi
  
index 3015d1e107dcedb60a38353b096fe681e8f4e6b7..e31f3e105eb760099d158c592d65f9d3d66e702b 100644 (file)
@@ -47,7 +47,7 @@ diff --git a/configure.ac b/configure.ac
 index ea422a86a9..3c1e2c088d 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2955,13 +2955,21 @@ PKG_PROG_PKG_CONFIG
+@@ -2961,13 +2961,21 @@ PKG_PROG_PKG_CONFIG
  AC_SUBST(DISABLED_EXTENSIONS)
  
  # Check for use of the system expat library
index dfe8614a5df67b0e1a8980330914364694225c2f..1b18c54591bc331d1a66ec7c960987b2b8b05ff3 100644 (file)
@@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index 3c1e2c088d..30a92f9c2e 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3230,6 +3230,12 @@ if test "$SQLITE3" = "no" ; then
+@@ -3251,6 +3251,12 @@ if test "$SQLITE3" = "no" ; then
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
  fi
  
index 35bfe5aed9066fbe9c924d122d1792511d7a037b..71645be9f41c5b4b103299d5ec2ec37ccefd212c 100644 (file)
@@ -15,7 +15,7 @@ diff --git a/configure.ac b/configure.ac
 index 30a92f9c2e..20f326db46 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3236,6 +3236,12 @@ AC_ARG_ENABLE(codecs-cjk,
+@@ -3257,6 +3257,12 @@ AC_ARG_ENABLE(codecs-cjk,
                DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk _codecs_iso2022"
        fi])
  
index a8ec0e499fc3caf614e4a4c9a9d801b37edba363..3805e1aad91c3792b278a312044c11acc5f4db9a 100644 (file)
@@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index 20f326db46..99bbc37b07 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3242,6 +3242,12 @@ AC_ARG_ENABLE(nis,
+@@ -3263,6 +3263,12 @@ AC_ARG_ENABLE(nis,
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
          fi])
  
index bb23879e349915c83c60598333bae33b607eb562..3a138f966fed85954d442add15865f399550171f 100644 (file)
@@ -52,7 +52,7 @@ diff --git a/configure.ac b/configure.ac
 index 99bbc37b07..8c9706582e 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3284,6 +3284,12 @@ AC_ARG_ENABLE(lib2to3,
+@@ -3305,6 +3305,12 @@ AC_ARG_ENABLE(lib2to3,
        AS_HELP_STRING([--disable-lib2to3], [disable lib2to3]),
        [ LIB2TO3="${enableval}" ], [ LIB2TO3=yes ])
  
index 7d96f5c4162c4ee0532458ae5efba1f09e1231d6..5906f9d3854fff7dff555119268e670d09f6c321 100644 (file)
@@ -20,7 +20,7 @@ diff --git a/configure.ac b/configure.ac
 index 8c9706582e..e6255babb6 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3006,13 +3006,20 @@ fi
+@@ -3012,13 +3012,20 @@ fi
  AC_SUBST(LIBFFI_INCLUDEDIR)
  
  # Check for use of the system libmpdec library
@@ -44,8 +44,8 @@ index 8c9706582e..e6255babb6 100644
 +fi
 +AC_SUBST(MPDEC)
  
- # Check for support for loadable sqlite extensions
- AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
+ # Check whether _decimal should use a coroutine-local or thread-local context
+ AC_MSG_CHECKING(for --with-decimal-contextvar)
 diff --git a/setup.py b/setup.py
 index 9f09b3d985..a7f2e23d87 100644
 --- a/setup.py
index 56f56adfcb952f0608d9fcd76bbb163d3479f359..55ba22a0e5aa5a5b1509d75b619b4387f18a78c2 100644 (file)
@@ -12,9 +12,9 @@ diff --git a/configure.ac b/configure.ac
 index e6255babb6..5809233aac 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3021,6 +3021,12 @@ else
- fi
- AC_SUBST(MPDEC)
+@@ -3042,6 +3042,12 @@ fi
+ AC_MSG_RESULT($with_decimal_contextvar)
  
 +AC_ARG_ENABLE(ossaudiodev,
 +      AS_HELP_STRING([--disable-ossaudiodev], [disable OSSAUDIODEV]),
index ced3fa93e760f8306d408af90cd2323acb1e2793..814ffdb5610fa03f32c8e96b6e051f91feb3cb71 100644 (file)
@@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index 5809233aac..6b09bafda4 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3261,6 +3261,12 @@ AC_ARG_ENABLE(unicodedata,
+@@ -3282,6 +3282,12 @@ AC_ARG_ENABLE(unicodedata,
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} unicodedata"
          fi])
  
index e70c9984e48e12a8dda20fb04e851e4c4a5f7a4a..30651244f4f602e36123b37224c44730ff22f7eb 100644 (file)
@@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index 6b09bafda4..b64518eed5 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3267,6 +3267,12 @@ AC_ARG_ENABLE(openssl,
+@@ -3288,6 +3288,12 @@ AC_ARG_ENABLE(openssl,
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
          fi])
  
index 004b3d1c8f70f4abb4bd897ce231c0f2259f60d6..330b549c018a016a1799069637300f1eea3cc116 100644 (file)
@@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index b64518eed5..d07e371c57 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3273,6 +3273,24 @@ AC_ARG_ENABLE(readline,
+@@ -3294,6 +3294,24 @@ AC_ARG_ENABLE(readline,
             DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} readline"
          fi])
  
index a777475c9e62d8bee9f88c2a89d73006763fba60..6ea5f6859040f58b6f126540f2636445333de7f7 100644 (file)
@@ -12,7 +12,7 @@ diff --git a/configure.ac b/configure.ac
 index d07e371c57..55ab6c3c26 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -3309,6 +3309,15 @@ if test "$CURSES" = "no"; then
+@@ -3330,6 +3330,15 @@ if test "$CURSES" = "no"; then
     DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
  fi
  
index 5a5a104dc591cc8f4cb4e4ec4c1525d2b1fb042a..2f5f7a8bf0707b7eb50711777d3017a248b0f3d0 100644 (file)
@@ -32,7 +32,7 @@ diff --git a/configure.ac b/configure.ac
 index 55ab6c3c26..4a6d0662ac 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -700,7 +700,9 @@ then
+@@ -706,7 +706,9 @@ then
  fi
  
  
index cb7c6b2f2542773bfcd628463b812a18f1a4fd2d..fc34e8aa592dc26c705401801bba7430082bd173 100644 (file)
@@ -1,5 +1,5 @@
-# From https://www.python.org/downloads/release/python-382/
-md5  e9d6ebc92183a177b8e8a58cad5b8d67  Python-3.8.2.tar.xz
+# From https://www.python.org/downloads/release/python-383/
+md5  3000cf50aaa413052aef82fd2122ca78  Python-3.8.3.tar.xz
 # Locally computed
-sha256  2646e7dc233362f59714c6193017bb2d6f7b38d6ab4a0cb5fbac5c36c4d845df  Python-3.8.2.tar.xz
+sha256  dfab5ec723c218082fe3d5d7ae17ecbdebffa9a1aea4d64aa3a2ecdd2e795864  Python-3.8.3.tar.xz
 sha256  de4d1f2d2ad5ad0cfd1657a106476b31cb5db5ef9d1ff842b237c0c81f0c8a23  LICENSE
index 2656037efd924e3a8de42200659f3e5d72d2f25d..4e43027cffcf1e10227ad692fa18bec505317690 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PYTHON3_VERSION_MAJOR = 3.8
-PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).2
+PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).3
 PYTHON3_SOURCE = Python-$(PYTHON3_VERSION).tar.xz
 PYTHON3_SITE = https://python.org/ftp/python/$(PYTHON3_VERSION)
 PYTHON3_LICENSE = Python-2.0, others