package/libyang: new package
authorHeiko Thiery <heiko.thiery@kontron.com>
Fri, 11 Oct 2019 12:40:42 +0000 (14:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 22 Oct 2019 21:30:38 +0000 (23:30 +0200)
LibYANG processes YIN and YANG files. It's a dependency of sysrepo
which is a dependency of Netopeer, a NETCONF/YANG server.

Signed-off-by: Heiko Thiery <heiko.thiery@kontron.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libyang/Config.in [new file with mode: 0644]
package/libyang/libyang.hash [new file with mode: 0644]
package/libyang/libyang.mk [new file with mode: 0644]

index 1810eb41eb7461a995983292aed387c467aa88cc..e934f079eb83b06ab0f479cfb84d448122bd0c9a 100644 (file)
@@ -1042,6 +1042,9 @@ F:        package/python-markdown/
 F:     package/python-remi/
 F:     package/python-sip/
 
+N:     Heiko Thiery <heiko.thiery@gmail.com>
+F:     package/libyang/
+
 N:     Henrique Camargo <henrique@henriquecamargo.com>
 F:     package/json-glib/
 
index ca95173fbc0287af83b4d270f3c25fc4a1b53256..8d6fb647a6b150836f6c860ee4b08756cd682f27 100644 (file)
@@ -1651,6 +1651,7 @@ menu "Networking"
        source "package/libvncserver/Config.in"
        source "package/libwebsock/Config.in"
        source "package/libwebsockets/Config.in"
+       source "package/libyang/Config.in"
        source "package/lksctp-tools/Config.in"
        source "package/mongoose/Config.in"
        source "package/nanomsg/Config.in"
diff --git a/package/libyang/Config.in b/package/libyang/Config.in
new file mode 100644 (file)
index 0000000..ebe51ff
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBYANG
+       bool "libyang"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_PCRE
+       select BR2_PACKAGE_PCRE_UCP
+       help
+         Libyang is YANG data modeling language parser and toolkit
+         written (and providing API) in C.
+
+         https://github.com/CESNET/libyang
+
+comment "libyang needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/libyang/libyang.hash b/package/libyang/libyang.hash
new file mode 100644 (file)
index 0000000..4989873
--- /dev/null
@@ -0,0 +1,2 @@
+sha256 351f712433d50494aad153bfd4aa92ff50299058428620eabddb7a41d781e756  libyang-v1.0-r3.tar.gz
+sha256 f942fe693e03e4e3ff67a351c00dc8f468a042e0d7273b0aa6bc53060b568112  LICENSE
diff --git a/package/libyang/libyang.mk b/package/libyang/libyang.mk
new file mode 100644 (file)
index 0000000..a120f51
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# libyang
+#
+################################################################################
+
+LIBYANG_VERSION = v1.0-r3
+LIBYANG_SITE = $(call github,CESNET,libyang,$(LIBYANG_VERSION))
+LIBYANG_LICENSE = BSD-3-Clause
+LIBYANG_LICENSE_FILES = LICENSE
+LIBYANG_INSTALL_STAGING = YES
+LIBYANG_SUPPORTS_IN_SOURCE_BUILD = NO
+LIBYANG_DEPENDENCIES = pcre
+HOST_LIBYANG_DEPENDENCIES = host-pcre
+
+LIBYANG_CONF_OPTS = \
+       -DENABLE_VALGRIND_TESTS=OFF \
+       -DGEN_PYTHON_BINDINGS=OFF
+
+HOST_LIBYANG_CONF_OPTS = \
+       -DENABLE_VALGRIND_TESTS=OFF \
+       -DGEN_PYTHON_BINDINGS=OFF
+
+$(eval $(cmake-package))
+$(eval $(host-cmake-package))