toolchain-external: fix bug #5054
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 11 May 2013 04:49:34 +0000 (04:49 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 May 2013 19:52:22 +0000 (21:52 +0200)
The external toolchain logic checks (and finds) the proper ARCH_LIB_DIR
and forcibly copies it to */lib even if it's in */lib64
This is all well until the check is done for create_lib64_symlinks which
only verifies if ARCH_SYSROOT_DIR/lib64 is a symlink, which in some
toolchain it's a real directory (like sourcery x86_64 2012.09) and thus
doesn't make the symlink in the target.

Fix this by also checking for a real directory.

Easily reproducible by running "make qemu_x86_64_defconfig", switching
to an external toolchain before build, building and then trying to run
the resulting image.

Closes bug #5054

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
toolchain/toolchain-external/ext-tool.mk

diff --git a/CHANGES b/CHANGES
index 97f5a4d88a52063efd157baaf17f872a987d1850..04c1eeddd165ee4ecf1e834adcd5e4c1828ffedb 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -6,6 +6,10 @@
        libcurl, pulseaudio, python-nfc, qt5imageformats, strace,
        wvstreams
 
+       Issues resolved (http://bugs.uclibc.org):
+
+       #5054: amd64: cannot find init - due to missing /lib64 folder
+
 2013.05-rc1, Released May 8th, 2013:
 
        Architectures: ARC support, Blackfin support, FLAT binary
index bf2bee8683f3ffa53e246bd79f3a334fba416fc6..a87bc3b5a69d333a66a416f0655fdd8b1656b084 100644 (file)
@@ -446,7 +446,7 @@ $(STAMP_DIR)/ext-toolchain-installed: $(STAMP_DIR)/ext-toolchain-checked
        fi ; \
        $(call MESSAGE,"Copying external toolchain sysroot to staging...") ; \
        $(call copy_toolchain_sysroot,$${SYSROOT_DIR},$${ARCH_SYSROOT_DIR},$${ARCH_SUBDIR},$${ARCH_LIB_DIR},$${SUPPORT_LIB_DIR}) ; \
-       if [ -L $${ARCH_SYSROOT_DIR}/lib64 ] ; then \
+       if [ -L $${ARCH_SYSROOT_DIR}/lib64 -o -d $${ARCH_SYSROOT_DIR}/lib64 ] ; then \
                $(call create_lib64_symlinks) ; \
        fi ; \
        if test x"$(BR2_TOOLCHAIN_EXTERNAL_GDB_SERVER_COPY)" == x"y"; then \