package/pkg-meson.mk: determine 'buildtype' based on BR2_ENABLE_RUNTIME_DEBUG iso...
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 1 Jun 2021 14:34:20 +0000 (16:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 1 Jun 2021 20:40:10 +0000 (22:40 +0200)
BR2_ENABLE_DEBUG should just steer the availability of debug symbols and
should have no negative effect on performance.

Introduction of 'assert' statements, 'debug'-type builds with additional
logging, etc. should be steered by BR2_ENABLE_RUNTIME_DEBUG instead.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-meson.mk

index a57820d4d296d6e7cb4e22d17399c5dfb0d0d4f3..dafad3b1ebda8978858cb9ca8adec84a8305ba62 100644 (file)
@@ -89,7 +89,7 @@ define $(2)_CONFIGURE_CMDS
                --prefix=/usr \
                --libdir=lib \
                --default-library=$(if $(BR2_STATIC_LIBS),static,shared) \
-               --buildtype=$(if $(BR2_ENABLE_DEBUG),debug,release) \
+               --buildtype=$(if $(BR2_ENABLE_RUNTIME_DEBUG),debug,release) \
                --cross-file=$$($$(PKG)_SRCDIR)/build/cross-compilation.conf \
                -Dstrip=false \
                -Dbuild.pkg_config_path=$$(HOST_DIR)/lib/pkgconfig \