linux-fusion: add dependency on !BR2_KERNEL_none
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 May 2010 16:13:52 +0000 (18:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 May 2010 21:41:51 +0000 (23:41 +0200)
linux-fusion is composed of a kernel module, and linux-fusion.mk uses
several variable definitions that only exist when Buildroot compiles a
kernel.

We also add the same dependency to BR2_PACKAGE_DIRECTFB_MULTI, which
relies on linux-fusion.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/directfb/Config.in
package/linux-fusion/Config.in

index 5e81b7ede8b03132bcc6f6125eead9f4d1c558e2..8a0a736129ce4c9f5e52fbf0afc7fd3026153737 100644 (file)
@@ -10,6 +10,7 @@ if BR2_PACKAGE_DIRECTFB
 config BR2_PACKAGE_DIRECTFB_MULTI
        bool "directfb multi application"
        select BR2_PACKAGE_LINUX_FUSION
+       depends on !BR2_KERNEL_none
        help
          Enable use of multiple concurrent DirectFB applications
 
index 6fb5260768be18e2a2b2b6b4efd59b9e125c4ea6..ebd00b4575a55f8dcb75677567bef4899da8206f 100644 (file)
@@ -1,4 +1,5 @@
 config BR2_PACKAGE_LINUX_FUSION
+       depends on !BR2_KERNEL_none
        bool "linux-fusion communication layer for DirectFB multi"
        help
          DirectFB Communication Layer allowing multiple DirectFB