bind: not available for static builds
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 28 Nov 2014 10:25:27 +0000 (07:25 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 28 Nov 2014 11:07:52 +0000 (12:07 +0100)
Fixes:
http://autobuild.buildroot.net/results/e27/e27111f484f72c77d2179fa1a29ea7b5271ff9fa/

While at it rename patches to new convention.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bind/0001-disable-tests.patch [new file with mode: 0644]
package/bind/0002-cross.patch [new file with mode: 0644]
package/bind/Config.in
package/bind/bind-01-disable-tests.patch [deleted file]
package/bind/bind-02-cross.patch [deleted file]

diff --git a/package/bind/0001-disable-tests.patch b/package/bind/0001-disable-tests.patch
new file mode 100644 (file)
index 0000000..181b229
--- /dev/null
@@ -0,0 +1,28 @@
+Disable tests to avoid cross-compilation issues (tries to run genrandom).
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura bind-9.9.4-P2.orig/bin/Makefile.in bind-9.9.4-P2/bin/Makefile.in
+--- bind-9.9.4-P2.orig/bin/Makefile.in 2013-12-19 21:28:28.000000000 -0300
++++ bind-9.9.4-P2/bin/Makefile.in      2014-01-17 11:41:25.378784210 -0300
+@@ -19,7 +19,7 @@
+ VPATH =               @srcdir@
+ top_srcdir =  @top_srcdir@
+-SUBDIRS =     named rndc dig dnssec tools tests nsupdate \
++SUBDIRS =     named rndc dig dnssec tools nsupdate \
+               check confgen @PYTHON_TOOLS@ @PKCS11_TOOLS@
+ TARGETS =
+diff -Nura bind-9.9.4-P2.orig/lib/Makefile.in bind-9.9.4-P2/lib/Makefile.in
+--- bind-9.9.4-P2.orig/lib/Makefile.in 2013-12-19 21:28:28.000000000 -0300
++++ bind-9.9.4-P2/lib/Makefile.in      2014-01-17 11:41:30.489954861 -0300
+@@ -23,7 +23,7 @@
+ # Attempt to disable parallel processing.
+ .NOTPARALLEL:
+ .NO_PARALLEL:
+-SUBDIRS =     isc isccc dns isccfg bind9 lwres tests
++SUBDIRS =     isc isccc dns isccfg bind9 lwres
+ TARGETS =
+ @BIND9_MAKE_RULES@
diff --git a/package/bind/0002-cross.patch b/package/bind/0002-cross.patch
new file mode 100644 (file)
index 0000000..5b4b1cd
--- /dev/null
@@ -0,0 +1,18 @@
+Use host compiler to build 'gen' since it's run when building.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura bind-9.5.1-P1/lib/dns/Makefile.in bind-9.5.1-P1.gencross/lib/dns/Makefile.in
+--- bind-9.5.1-P1/lib/dns/Makefile.in  2007-09-11 22:09:08.000000000 -0300
++++ bind-9.5.1-P1.gencross/lib/dns/Makefile.in 2009-03-04 16:35:23.000000000 -0200
+@@ -160,8 +160,8 @@
+       ./gen -s ${srcdir} > code.h
+
+ gen: gen.c
+-      ${BUILD_CC} ${BUILD_CFLAGS} -I${top_srcdir}/lib/isc/include \
+-      ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} -o $@ ${srcdir}/gen.c ${BUILD_LIBS}
++      ${HOSTCC} ${HOST_CFLAGS} -I${top_srcdir}/lib/isc/include \
++      ${HOST_LDFLAGS} -o $@ ${srcdir}/gen.c
+
+ rbtdb64.@O@: rbtdb.c
+
index 4f65e1ce168ab7fda54fe04f82dc62603c84b27e..8e3b8242871a87b5b18c19d6afc113428cd25370 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_BIND
        depends on BR2_INET_IPV6
        depends on BR2_LARGEFILE
        depends on BR2_USE_MMU # fork()
+       depends on !BR2_PREFER_STATIC_LIB
        help
          BIND (Berkeley Internet Name Domain) is an implementation of
          the Domain Name System (DNS) protocols and provides an openly
@@ -38,6 +39,6 @@ config BR2_PACKAGE_BIND_TOOLS
 
 endif
 
-comment "bind needs a toolchain w/ largefile, IPv6"
+comment "bind needs a toolchain w/ largefile, IPv6, dynamic library"
        depends on BR2_USE_MMU
-       depends on !(BR2_LARGEFILE || BR2_INET_IPV6)
+       depends on !BR2_LARGEFILE || !BR2_INET_IPV6 || BR2_PREFER_STATIC_LIB
diff --git a/package/bind/bind-01-disable-tests.patch b/package/bind/bind-01-disable-tests.patch
deleted file mode 100644 (file)
index 181b229..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-Disable tests to avoid cross-compilation issues (tries to run genrandom).
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura bind-9.9.4-P2.orig/bin/Makefile.in bind-9.9.4-P2/bin/Makefile.in
---- bind-9.9.4-P2.orig/bin/Makefile.in 2013-12-19 21:28:28.000000000 -0300
-+++ bind-9.9.4-P2/bin/Makefile.in      2014-01-17 11:41:25.378784210 -0300
-@@ -19,7 +19,7 @@
- VPATH =               @srcdir@
- top_srcdir =  @top_srcdir@
--SUBDIRS =     named rndc dig dnssec tools tests nsupdate \
-+SUBDIRS =     named rndc dig dnssec tools nsupdate \
-               check confgen @PYTHON_TOOLS@ @PKCS11_TOOLS@
- TARGETS =
-diff -Nura bind-9.9.4-P2.orig/lib/Makefile.in bind-9.9.4-P2/lib/Makefile.in
---- bind-9.9.4-P2.orig/lib/Makefile.in 2013-12-19 21:28:28.000000000 -0300
-+++ bind-9.9.4-P2/lib/Makefile.in      2014-01-17 11:41:30.489954861 -0300
-@@ -23,7 +23,7 @@
- # Attempt to disable parallel processing.
- .NOTPARALLEL:
- .NO_PARALLEL:
--SUBDIRS =     isc isccc dns isccfg bind9 lwres tests
-+SUBDIRS =     isc isccc dns isccfg bind9 lwres
- TARGETS =
- @BIND9_MAKE_RULES@
diff --git a/package/bind/bind-02-cross.patch b/package/bind/bind-02-cross.patch
deleted file mode 100644 (file)
index 5b4b1cd..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Use host compiler to build 'gen' since it's run when building.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura bind-9.5.1-P1/lib/dns/Makefile.in bind-9.5.1-P1.gencross/lib/dns/Makefile.in
---- bind-9.5.1-P1/lib/dns/Makefile.in  2007-09-11 22:09:08.000000000 -0300
-+++ bind-9.5.1-P1.gencross/lib/dns/Makefile.in 2009-03-04 16:35:23.000000000 -0200
-@@ -160,8 +160,8 @@
-       ./gen -s ${srcdir} > code.h
-
- gen: gen.c
--      ${BUILD_CC} ${BUILD_CFLAGS} -I${top_srcdir}/lib/isc/include \
--      ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} -o $@ ${srcdir}/gen.c ${BUILD_LIBS}
-+      ${HOSTCC} ${HOST_CFLAGS} -I${top_srcdir}/lib/isc/include \
-+      ${HOST_LDFLAGS} -o $@ ${srcdir}/gen.c
-
- rbtdb64.@O@: rbtdb.c
-