pkg-perl: fix build of perl XS packages
authorFrancois Perrad <fperrad@gmail.com>
Thu, 14 Aug 2014 18:49:59 +0000 (20:49 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 15 Aug 2014 08:19:14 +0000 (10:19 +0200)
Set OPTIMIZE in order to avoid the use of the host $Config{optimize} value
which could cause breakage when cross-compiling for the target.

See discussion in http://lists.busybox.net/pipermail/buildroot/2014-August/104129.html

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-perl.mk

index f073d70a8a3b42f01236debec84e64b7f28c0ceb..51eaf5259b15efae4e0f7f20a98dadfad80b1744 100644 (file)
@@ -56,6 +56,7 @@ define $(2)_CONFIGURE_CMDS
                        --config full_ar="$$(TARGET_AR)" \
                        --config cc="$$(TARGET_CC)" \
                        --config ccflags="$$(TARGET_CFLAGS)" \
+                       --config optimize=" " \
                        --config ld="$$(TARGET_CC)" \
                        --config lddlflags="-shared $$(TARGET_LDFLAGS)" \
                        --config ldflags="$$(TARGET_LDFLAGS)" \
@@ -78,6 +79,7 @@ define $(2)_CONFIGURE_CMDS
                        FULL_AR="$$(TARGET_AR)" \
                        CC="$$(TARGET_CC)" \
                        CCFLAGS="$$(TARGET_CFLAGS)" \
+                       OPTIMIZE=" " \
                        LD="$$(TARGET_CC)" \
                        LDDLFLAGS="-shared $$(TARGET_LDFLAGS)" \
                        LDFLAGS="$$(TARGET_LDFLAGS)" \