package/erlang: patch the tarball
authorJohan Oudinet <johan.oudinet@gmail.com>
Mon, 10 Feb 2020 16:58:24 +0000 (17:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 19 Feb 2020 19:56:01 +0000 (20:56 +0100)
Remove the lib/ssl/src/deps directory before configuring the package.
Otherwise, during the compilation of the ssl app, it may fails by
looking for logger.hrl in the wrong location (bootstrap/lib/kernel
instead of lib/kernel).

Fixes:

  http://autobuild.buildroot.net/results/97606fcd11eaf0822b58a9532c5325601d43eaac/

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Tested-by: Frank Vanbever <frank.vanbever@essensium.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/erlang/erlang.mk

index 3dabfd40b951e27c0fe26115485822b9a0cdcf87..9cedb62e05f4251a36d28e0a8326e5480559b4d3 100644 (file)
@@ -14,6 +14,13 @@ ERLANG_LICENSE = Apache-2.0
 ERLANG_LICENSE_FILES = LICENSE.txt
 ERLANG_INSTALL_STAGING = YES
 
+# Remove the leftover deps directory from the ssl app
+# See https://bugs.erlang.org/browse/ERL-1168
+define ERLANG_REMOVE_SSL_DEPS
+       rm -rf $(@D)/lib/ssl/src/deps
+endef
+ERLANG_POST_PATCH_HOOKS += ERLANG_REMOVE_SSL_DEPS
+
 # Patched erts/aclocal.m4
 define ERLANG_RUN_AUTOCONF
        cd $(@D) && PATH=$(BR_PATH) ./otp_build autoconf