package/python-msgfy: new package
authorAsaf Kahlon <asafka7@gmail.com>
Sat, 19 Oct 2019 18:21:25 +0000 (21:21 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 19 Oct 2019 18:26:38 +0000 (20:26 +0200)
Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/Config.in
package/python-msgfy/Config.in [new file with mode: 0644]
package/python-msgfy/python-msgfy.hash [new file with mode: 0644]
package/python-msgfy/python-msgfy.mk [new file with mode: 0644]

index ac02b84db40c5b3141cee9edf87389a07949a67c..c8ff524e83a7bcf65559c8adee5247e8dba46708 100644 (file)
@@ -963,6 +963,7 @@ menu "External python modules"
        source "package/python-mimeparse/Config.in"
        source "package/python-mistune/Config.in"
        source "package/python-more-itertools/Config.in"
+       source "package/python-msgfy/Config.in"
        source "package/python-msgpack/Config.in"
        source "package/python-multidict/Config.in"
        source "package/python-mutagen/Config.in"
diff --git a/package/python-msgfy/Config.in b/package/python-msgfy/Config.in
new file mode 100644 (file)
index 0000000..7875379
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_MSGFY
+       bool "python-msgfy"
+       help
+         msgfy is a Python library for convert Exception instance to
+         a human-readable error message.
+
+         https://github.com/thombashi/msgfy
diff --git a/package/python-msgfy/python-msgfy.hash b/package/python-msgfy/python-msgfy.hash
new file mode 100644 (file)
index 0000000..8f664ec
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/msgfy/json
+md5    3a94f49d7b31cc7bca21e0a9bfadf767  msgfy-0.0.7.tar.gz
+sha256 370c54bb036d3728af8004e750b7cd7bc5a4ac25f9cdb8be13b7865cae3c73ee  msgfy-0.0.7.tar.gz
+# Locally computed sha256 checksums
+sha256 fcfe96f8fb1bf3478a51c828e7f7afee01500ce1c2d4345d052edb858be05227  LICENSE
diff --git a/package/python-msgfy/python-msgfy.mk b/package/python-msgfy/python-msgfy.mk
new file mode 100644 (file)
index 0000000..0a642b4
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-msgfy
+#
+################################################################################
+
+PYTHON_MSGFY_VERSION = 0.0.7
+PYTHON_MSGFY_SOURCE = msgfy-$(PYTHON_MSGFY_VERSION).tar.gz
+PYTHON_MSGFY_SITE = https://files.pythonhosted.org/packages/23/82/b61a8353c36e60c2c8291c56ad7d00aa37918ef56811727510acada09f7f
+PYTHON_MSGFY_SETUP_TYPE = setuptools
+PYTHON_MSGFY_LICENSE = MIT
+PYTHON_MSGFY_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))