package: proper aclocal fix
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Mar 2009 19:10:26 +0000 (19:10 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Mar 2009 19:10:26 +0000 (19:10 -0000)
Revert r25827 and instead copy over the host aclocal files of the stuff
needed for auto* (libtool + pkgconfig). These logically belong with the
target stuff, as they are used for the target auto* toolchain.

Long term we should probably consider using
aclocal --acdir=$(STAGING_DIR)/usr/share/aclocal, so the host .m4 files
cannot interfere with the target build.

package/automake/automake.mk
package/libtool/libtool.mk
package/pkgconfig/pkgconfig.mk

index d65cd23388f52a07916eae4ca65941d703623dd2..6b87caa92c83027a516a296ba4fc2850a76e4e76 100644 (file)
@@ -20,7 +20,7 @@ AUTOMAKE_HOST_DIR:=$(BUILD_DIR)/automake-$(AUTOMAKE_VERSION)-host
 
 # variables used by other packages
 AUTOMAKE:=$(HOST_DIR)/usr/bin/automake
-ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
+ACLOCAL_DIR = $(STAGING_DIR)/usr/share/aclocal
 ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)
 
 $(DL_DIR)/$(AUTOMAKE_SOURCE):
@@ -51,6 +51,7 @@ $(STAMP_DIR)/host_automake_compiled: $(STAMP_DIR)/host_automake_configured
 
 $(STAMP_DIR)/host_automake_installed: $(STAMP_DIR)/host_automake_compiled
        $(MAKE) -C $(AUTOMAKE_HOST_DIR) install
+       mkdir -p $(STAGING_DIR)/usr/share/aclocal
        touch $@
 
 host-automake: $(STAMP_DIR)/host_automake_installed
index a649a7435dce0fe9d8baf1f5127d61f49e7c8ce5..1f56fdd3b1e40f105a43af357f636e6d67fefcbe 100644 (file)
@@ -49,6 +49,10 @@ $(STAMP_DIR)/host_libtool_compiled: $(STAMP_DIR)/host_libtool_configured
 
 $(STAMP_DIR)/host_libtool_installed: $(STAMP_DIR)/host_libtool_compiled
        $(MAKE) -C $(LIBTOOL_HOST_DIR) install
+       install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/libtool.m4 \
+               $(STAGING_DIR)/usr/share/aclocal/libtool.m4
+       install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/ltdl.m4 \
+               $(STAGING_DIR)/usr/share/aclocal/ltdl.m4
        touch $@
 
 host-libtool: $(STAMP_DIR)/host_libtool_installed
index 7310aae50457e60a8d0638e8c297ff00b540bc88..34df017613ee2055a8d3b5013a9d47941b6074fa 100644 (file)
@@ -50,6 +50,8 @@ $(STAMP_DIR)/host_pkgconfig_compiled: $(STAMP_DIR)/host_pkgconfig_configured
 
 $(STAMP_DIR)/host_pkgconfig_installed: $(STAMP_DIR)/host_pkgconfig_compiled
        $(MAKE) -C $(PKG_CONFIG_HOST_DIR) install
+       install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/pkg.m4 \
+               $(STAGING_DIR)/usr/share/aclocal/pkg.m4
        touch $@
 
 host-pkgconfig: $(STAMP_DIR)/host_pkgconfig_installed