toolchain-external: fix registration of hook for Sourcery Aarch64 toolchain
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 May 2016 13:05:14 +0000 (15:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 May 2016 13:05:14 +0000 (15:05 +0200)
As noticed by Romain Naour, commit
4d39ca1c2ab19766abf0430abe9b65ba0e16602b ("toolchain-external: fix
installation for CodeSourcery AArch64 toolchain") has a small bug where
a post-install hook doing fixups in TARGET_DIR was registered as a
staging installation hook while it should have been registered as a
target installation hook. This commit fixes this inconsistency.

Reported-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/toolchain-external.mk

index 0ca4b9182abf9a2548fc0b42b04f0eb24e52e45c..24c1f0360cd2097746493b507ac76fa671fe8035 100644 (file)
@@ -384,7 +384,7 @@ TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_CODESOURCERY
 define TOOLCHAIN_EXTERNAL_CODESOURCERY_AARCH64_TARGET_FIXUP
        ln -sf ld-2.20.so $(TARGET_DIR)/lib/ld-linux-aarch64.so.1
 endef
-TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_CODESOURCERY_AARCH64_TARGET_FIXUP
+TOOLCHAIN_EXTERNAL_POST_INSTALL_TARGET_HOOKS += TOOLCHAIN_EXTERNAL_CODESOURCERY_AARCH64_TARGET_FIXUP
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS),y)
 TOOLCHAIN_EXTERNAL_VERSION = 1.1.12
 TOOLCHAIN_EXTERNAL_SITE = https://googledrive.com/host/0BwnS5DMB0YQ6bDhPZkpOYVFhbk0/musl-$(TOOLCHAIN_EXTERNAL_VERSION)