opencv: add zlib dependency
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 May 2012 05:11:22 +0000 (05:11 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 May 2012 19:00:16 +0000 (21:00 +0200)
The opencv package selects zlib, but it does not depend on it. This
leads to cases where opencv gets built before zlib, and in this case,
opencv uses its internal version of zlib, which doesn't build properly
(it has some conditional code for ARM that is probably broken), see:

  http://autobuild.buildroot.org/results/45f4e195fe0cc5acace10287f5ff33aa953d5430/build-end.log

We fix this by properly adding the opencv dependency on zlib.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/opencv/opencv.mk

index d415e5192e05fcf29c13a82fc479e35b9d868a00..ec9471518ff9f5191562d0516378978759c95320 100644 (file)
@@ -35,6 +35,8 @@ OPENCV_CONF_OPT = \
        -DWITH_UNICAP=OFF \
        -DWITH_XINE=OFF
 
+OPENCV_DEPENDENCIES += zlib
+
 ifeq ($(BR2_PACKAGE_OPENCV_WITH_PYTHON),y)
 OPENCV_CONF_OPT += -DBUILD_NEW_PYTHON_SUPPORT=ON
 OPENCV_DEPENDENCIES += python