package/pkg-golang: do not set static linking for host target
authorMirza Krak <mirza.krak@northern.tech>
Mon, 10 Jun 2019 15:40:07 +0000 (17:40 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 10 Jun 2019 18:44:08 +0000 (20:44 +0200)
The current logic will set the "-static" flag when building go
host packages if BR2_STATIC_LIBS is set, this will not work as
there is no support to link host packages statically.

Fix this by applying this logic only for target builds.

Signed-off-by: Mirza Krak <mirza.krak@northern.tech>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/pkg-golang.mk

index 72e8f6b7afa38a3822e18608d29c1c05e9434ab3..e47de17aba65cff8629b89d3242061dd9204783f 100644 (file)
@@ -58,10 +58,6 @@ define inner-golang-package
 
 $(2)_WORKSPACE ?= _gopath
 
-ifeq ($(BR2_STATIC_LIBS),y)
-$(2)_LDFLAGS += -extldflags '-static'
-endif
-
 $(2)_BUILD_OPTS += \
        -ldflags "$$($(2)_LDFLAGS)" \
        -tags "$$($(2)_TAGS)" \
@@ -106,6 +102,11 @@ endif
 # file.
 ifndef $(2)_BUILD_CMDS
 ifeq ($(4),target)
+
+ifeq ($(BR2_STATIC_LIBS),y)
+$(2)_LDFLAGS += -extldflags '-static'
+endif
+
 # Build package for target
 define $(2)_BUILD_CMDS
        $$(foreach d,$$($(2)_BUILD_TARGETS),\