toolchain-external: add support for 'Sourcery CodeBench MIPS 2012.03'
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Dec 2012 13:23:20 +0000 (13:23 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 Dec 2012 08:21:51 +0000 (09:21 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 456407edd5941cc60d5fa3a2572b95fe0c8a0206..4e945267abc9de4a122793739d31806688853368 100644 (file)
@@ -102,6 +102,74 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
              Select BR2_SOFT_FLOAT
              Set BR2_TARGET_OPTIMIZATION to -mthumb
 
+config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203
+       bool "Sourcery CodeBench MIPS 2012.03"
+       depends on BR2_mips || BR2_mipsel
+       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
+       select BR2_INSTALL_LIBSTDCPP
+       help
+         Sourcery CodeBench toolchain for the MIPS architecture, from
+         Mentor Graphics. It uses gcc 4.6.3, binutils 2.21.53, glibc
+         2.15, uClibc 0.9.30 and gdb 7.2.50, kernel headers
+         3.2.10. It has support for the following variants:
+           - MIPS32 O32 big endian glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+           - MIPS64 big endian glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Disable BR2_SOFT_FLOAT
+           - MIPS32 O32 little endian glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS64 little endian glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS32 big endian soft float glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+           - MIPS64 big endian soft float glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Select BR2_SOFT_FLOAT
+           - MIPS32 little endian soft float glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS64 little endian soft float glibc
+             Select a MIPS generic core
+             Select the n64 ABI
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL
+           - MIPS32 big endian microMIPS glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -mips16
+           - MIPS32 little endian microMIPS glibc
+             Select a MIPS generic core
+             Disable BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
+           - MIPS32 big endian soft float microMIPS glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -mips16
+           - MIPS32 little endian soft float microMIPS glibc
+             Select a MIPS generic core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -EL -mips16
+           - MIPS32 big endian uclibc
+             Not usable in Buildroot yet.
+           - MIPS32 little endian uclibc
+             Not usable in Buildroot yet.
+           - MIPS32 big endian soft float uclibc
+             Not usable in Buildroot yet.
+           - MIPS32 little endian soft float uclibc
+             Not usable in Buildroot yet.
+
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
        bool "Sourcery CodeBench ARM 2011.03"
        depends on BR2_arm
@@ -640,6 +708,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201103
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109
+       default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203
        default "powerpc-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009
        default "powerpc-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201103
        default "sh-linux-gnu"           if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_SH201103
index 6236235b8756cf1d758174257f8af204f3c6f8f1..2d18af011b3b049d9bfb2de61c5a70ae7551ae3f 100644 (file)
@@ -202,6 +202,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.03-110-mips-linux-gnu-i686-pc-linux-gnu.tar.
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201109),y)
 TOOLCHAIN_EXTERNAL_SITE=https://sourcery.mentor.com/GNUToolchain/package9761/public/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-2011.09-75-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS201203),y)
+TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu/
+TOOLCHAIN_EXTERNAL_SOURCE=mips-2012.03-63-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC201009),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/power/portal/package7703/public/powerpc-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=freescale-2010.09-55-powerpc-linux-gnu-i686-pc-linux-gnu.tar.bz2