host-mariadb: compile against bundled yassl
authorAdam Duskett <Aduskett@gmail.com>
Fri, 28 Jul 2017 10:44:40 +0000 (06:44 -0400)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 28 Jul 2017 22:05:25 +0000 (00:05 +0200)
On Fedora26, openssl 1.1.x is included by default.  This causes build
errors when building the host variant of mariadb.

Adding -DWITH_SSL=bundled fixes this issue.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mariadb/mariadb.mk

index 1d6c2bcc474239707faad9343cedc4023fc78536..db538fd0f2dd30364a3171efd3845613cd4ea27d 100644 (file)
@@ -67,6 +67,8 @@ MARIADB_CONF_OPTS += \
        -DMYSQL_DATADIR=/var/lib/mysql \
        -DMYSQL_UNIX_ADDR=$(MYSQL_SOCKET)
 
+HOST_MARIADB_CONF_OPTS += -DWITH_SSL=bundled
+
 # Some helpers must be compiled for host in order to crosscompile mariadb for
 # the target. They are then included by import_executables.cmake which is
 # generated during the build of the host helpers. It is not necessary to build