openssh: move systemd service files to /usr/lib
authorMike Williams <mike@mikebwilliams.com>
Fri, 20 Mar 2015 19:13:59 +0000 (15:13 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 19:37:16 +0000 (20:37 +0100)
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openssh/openssh.mk

index 08f3fa0f252ad1732c34a8eb4111f18d1c03776d..24af0798f4e6d51d3fcb4cd795db4fc6602a094c 100644 (file)
@@ -36,9 +36,9 @@ endif
 
 define OPENSSH_INSTALL_INIT_SYSTEMD
        $(INSTALL) -D -m 644 package/openssh/sshd.service \
-               $(TARGET_DIR)/etc/systemd/system/sshd.service
+               $(TARGET_DIR)/usr/lib/systemd/system/sshd.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -fs ../sshd.service \
+       ln -fs ../../../../usr/lib/systemd/system/sshd.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/sshd.service
 endef