strongswan: bump to version 5.3.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 8 Apr 2015 10:20:44 +0000 (07:20 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Apr 2015 19:14:11 +0000 (21:14 +0200)
Enable connmark and forecast plugins when iptables is selected.
And always enable the led plugin, though it's not new to 5.3.0.

[Thomas: also update hash file.]

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/strongswan/strongswan.hash
package/strongswan/strongswan.mk

index 6073b3656ee1c62b006bb9f83b3f02ed9e4105a8..626356a0bf240303df59a6693e1bce46f9f91482 100644 (file)
@@ -1,2 +1,2 @@
-# From http://download.strongswan.org/strongswan-5.2.2.tar.bz2.md5
-md5    7ee1a33060b2bde35be0f6d78a1d26d0        strongswan-5.2.2.tar.bz2
+# From http://download.strongswan.org/strongswan-5.3.0.tar.bz2.md5
+md5    c52d4228231c2025d9c320d0e9990327        strongswan-5.3.0.tar.bz2
index 059955d8b6d2921e880b7e38ca7223bbc4b7edd5..057870fa80e6245597e1bd00cc1b069bfd27d33b 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-STRONGSWAN_VERSION = 5.2.2
+STRONGSWAN_VERSION = 5.3.0
 STRONGSWAN_SOURCE = strongswan-$(STRONGSWAN_VERSION).tar.bz2
 STRONGSWAN_SITE = http://download.strongswan.org
 STRONGSWAN_LICENSE = GPLv2+
@@ -12,6 +12,7 @@ STRONGSWAN_LICENSE_FILES = COPYING LICENSE
 STRONGSWAN_DEPENDENCIES = host-pkgconf
 STRONGSWAN_CONF_OPTS += \
        --without-lib-prefix \
+       --enable-led \
        --enable-pkcs11=yes \
        --enable-kernel-netlink=$(if $(BR2_INET_IPV6),yes,no) \
        --enable-socket-default=$(if $(BR2_INET_IPV6),yes,no) \
@@ -70,4 +71,15 @@ STRONGSWAN_DEPENDENCIES += \
        $(if $(BR2_PACKAGE_MYSQL),mysql)
 endif
 
+ifeq ($(BR2_PACKAGE_IPTABLES),y)
+STRONGSWAN_DEPENDENCIES += iptables
+STRONGSWAN_CONF_OPTS += \
+       --enable-connmark \
+       --enable-forecast
+else
+STRONGSWAN_COF_OPTS += \
+       --disable-connmark \
+       --disable-forecast
+endif
+
 $(eval $(autotools-package))