boost: fix build failures after version bump
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 14 Oct 2013 14:15:11 +0000 (11:15 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 14 Oct 2013 20:52:50 +0000 (22:52 +0200)
Fix build failures that happened after the version bump such as:
http://autobuild.buildroot.net/results/570/570b091702763b29843d9207bc14dea67085fea0/
http://autobuild.buildroot.net/results/c26/c26498f1a4e6bcbc3a2dfce6a51fa7d21b72f21f/
and other failures by disabling the new (1.54+) coroutine and log
libraries which weren't handled and hence enabled by default.

These also made the target size bigger and build times longer
unnecessarily.

When/if they are needed for some future user this can be revisited and
their proper conditions for enablement assesed.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/boost/boost.mk

index a745ce1865ebaeb63cf84e0eedad2ae0382a03b8..b0b3352726272c3dd06fc798e1b8e763eba02201 100644 (file)
@@ -17,7 +17,9 @@ BOOST_DEPENDENCIES =
 BOOST_FLAGS =
 
 # atomic library compile only with upstream version, wait for next release
-BOOST_WITHOUT_FLAGS = python atomic
+# coroutine breaks on some weak toolchains and it's new for 1.54+
+# log breaks with some toolchain combinations and it's new for 1.54+
+BOOST_WITHOUT_FLAGS = atomic coroutine log python
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CONTEXT),,context)