package/systemd: add optional support for quotacheck
authorGabe Evans <gabe@hashrabbit.co>
Thu, 25 Feb 2016 21:55:22 +0000 (21:55 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 21:54:42 +0000 (22:54 +0100)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Thomas: rewrap Config.in help text.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 85dcf07639b31bd2264a094ec91429887de2f256..97d48c41247fb9f187184bad7a2a0dd1c2b97fb8 100644 (file)
@@ -110,6 +110,16 @@ config BR2_PACKAGE_SYSTEMD_BOOTCHART
 
          http://www.freedesktop.org/software/systemd/man/systemd-bootchart.html
 
+config BR2_PACKAGE_SYSTEMD_QUOTACHECK
+       bool "enable quotacheck tools"
+       help
+         systemd-quotacheck is a service responsible for file system
+         quota checks. It is run once at boot after all necessary
+         file systems are mounted. It is pulled in only if at least
+         one file system has quotas enabled.
+
+         http://www.freedesktop.org/software/systemd/man/systemd-quotacheck.service.html
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
        bool "enable network manager"
        help
index 626638836f403fe79a9b38f901cd4f484160b43f..b1d347d8546e56bca6578559592a218848e2e371 100644 (file)
@@ -149,6 +149,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-bootchart
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_QUOTACHECK),y)
+SYSTEMD_CONF_OPTS += --enable-quotacheck
+else
+SYSTEMD_CONF_OPTS += --disable-quotacheck
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK