libnl: handle all installed libraries
authorSven Neumann <s.neumann@raumfeld.com>
Mon, 19 Oct 2009 21:45:58 +0000 (23:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 21 Oct 2009 08:19:23 +0000 (10:19 +0200)
libnl does not only install libnl.so, but also libnl-nf.so,
libnl-genl.so and libnl-route.so. Change the post-install
and uninstall hooks to handle these libraries as well.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/libnl/libnl.mk

diff --git a/CHANGES b/CHANGES
index 20290ddae3f096b03be265875c40ce3497b7004b..b1f41352e118a6e8fb9f85587d5bc4d24b7ba6d4 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -6,11 +6,11 @@
        Updated/fixed packages: autoconf, busybox, directfb, dnsmasq,
        e2fsprogs, festival, gstreamer, gst-plugins-bad, gst-plugins-base,
        gst-plugins-good, imagemagick, iptables, kernel-headers, kismet,
-       libevent, libglib2, liblockfile, libmad, libupnp, libuuid, ltrace,
-       lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl, php,
-       python, quagga, radvd, rsync, samba, shared-mime-info, speech-tools,
-       squashfs, syslinux, u-boot, util-linux, valgrind, vsftpd, wipe,
-       wpa-supplicant, xdata_xcursor-themes, zlib
+       libevent, libglib2, liblockfile, libmad, libnl, libupnp, libuuid,
+       ltrace, lua, mdadm, ncftp, ncurses, netkittelnet, ntfs-3g, openssl,
+       php, python, quagga, radvd, rsync, samba, shared-mime-info,
+       speech-tools, squashfs, syslinux, u-boot, util-linux, valgrind,
+       vsftpd, wipe, wpa-supplicant, xdata_xcursor-themes, zlib
 
        Removed package: mdnsresponder, mpatrol
 
index 1a667468d74e2543804540df90f4b5ffbbb4eb11..04bac2dcae7d2e034faf79f8a5ad1af7b7e2800c 100644 (file)
@@ -13,10 +13,14 @@ LIBNL_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
 $(eval $(call AUTOTARGETS,package,libnl))
 
 $(LIBNL_HOOK_POST_INSTALL): $(LIBNL_TARGET_INSTALL_TARGET)
+ifneq ($(BR2_ENABLE_DEBUG),y)
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libnl.so*
+       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libnl-*.so*
+endif
        touch $@
 
 $(LIBNL_TARGET_UNINSTALL):
        $(call MESSAGE,"Uninstalling")
        rm -f $(TARGET_DIR)/usr/lib/libnl.so*
+       rm -f $(TARGET_DIR)/usr/lib/libnl-*.so*
        rm -f $(LIBNL_TARGET_INSTALL_TARGET) $(LIBNL_HOOK_POST_INSTALL)