package/vlc: add optional support for skins2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:35 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:37:06 +0000 (13:37 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 53a2b6163356718abacc6ad457d5dd60abf6c372..ed682e60b3cfa788116669bdd873672210d54f45 100644 (file)
@@ -74,7 +74,6 @@ VLC_CONF_OPTS += \
        --disable-schroedinger \
        --disable-shine \
        --disable-shout \
-       --disable-skins2 \
        --disable-sndio \
        --disable-spatialaudio \
        --disable-srt \
@@ -560,6 +559,13 @@ else
 VLC_CONF_OPTS += --without-x
 endif
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT)$(BR2_PACKAGE_XLIB_LIBXINERAMA)$(BR2_PACKAGE_XLIB_LIBXPM),yyy)
+VLC_CONF_OPTS += --enable-skins2
+VLC_DEPENDENCIES += xlib_libXext xlib_libXinerama xlib_libXpm
+else
+VLC_CONF_OPTS += --disable-skins2
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 VLC_DEPENDENCIES += zlib
 endif