teach newer fakeroot to not build docs
authorEric Andersen <andersen@codepoet.org>
Wed, 19 Apr 2006 17:53:45 +0000 (17:53 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 19 Apr 2006 17:53:45 +0000 (17:53 -0000)
package/fakeroot/fakeroot-doc.patch [new file with mode: 0644]
package/fakeroot/fakeroot.mk

diff --git a/package/fakeroot/fakeroot-doc.patch b/package/fakeroot/fakeroot-doc.patch
new file mode 100644 (file)
index 0000000..a5a5a93
--- /dev/null
@@ -0,0 +1,20 @@
+--- fakeroot/Makefile.am.orig  2006-04-19 11:50:35.000000000 -0600
++++ fakeroot/Makefile.am       2006-04-19 11:50:59.000000000 -0600
+@@ -1,5 +1,5 @@
+ AUTOMAKE_OPTIONS=foreign
+-SUBDIRS=scripts doc test
++SUBDIRS=scripts test
+ noinst_LTLIBRARIES = libcommunicate.la
+ libcommunicate_la_SOURCES = communicate.c
+--- fakeroot/Makefile.in.orig  2006-04-19 11:50:43.000000000 -0600
++++ fakeroot/Makefile.in       2006-04-19 11:51:21.000000000 -0600
+@@ -214,7 +214,7 @@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+ AUTOMAKE_OPTIONS = foreign
+-SUBDIRS = scripts doc test
++SUBDIRS = scripts test
+ noinst_LTLIBRARIES = libcommunicate.la
+ libcommunicate_la_SOURCES = communicate.c
+ lib_LTLIBRARIES = libfakeroot.la
index 13064613c85d4880d7afd2d86c53abffc2734bb4..a29940321c0bb41fce4d5fba997823c2ef4d6a33 100644 (file)
@@ -3,7 +3,7 @@
 # fakeroot
 #
 #############################################################
-FAKEROOT_VERSION:=1.2.13
+FAKEROOT_VERSION:=1.5.8
 FAKEROOT_SOURCE:=fakeroot_$(FAKEROOT_VERSION).tar.gz
 FAKEROOT_SITE:=http://ftp.debian.org/debian/pool/main/f/fakeroot
 FAKEROOT_CAT:=zcat
@@ -26,6 +26,7 @@ $(FAKEROOT_DIR1)/.unpacked: $(DL_DIR)/$(FAKEROOT_SOURCE)
        $(FAKEROOT_CAT) $(DL_DIR)/$(FAKEROOT_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
        $(SED) "s,getopt --version,getopt --version 2>/dev/null," \
                $(FAKEROOT_DIR1)/scripts/fakeroot.in
+       toolchain/patch-kernel.sh $(FAKEROOT_DIR1) package/fakeroot/ \*.patch
        touch $(FAKEROOT_DIR1)/.unpacked
 
 $(FAKEROOT_DIR1)/.configured: $(FAKEROOT_DIR1)/.unpacked
@@ -33,6 +34,7 @@ $(FAKEROOT_DIR1)/.configured: $(FAKEROOT_DIR1)/.unpacked
                CC="$(HOSTCC)" \
                ./configure \
                --prefix=/usr \
+               $(DISABLE_NLS) \
        );
        touch $(FAKEROOT_DIR1)/.configured