package/lxc: add optional dependency to bash-completion
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 12 Jan 2019 21:08:43 +0000 (22:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Jan 2019 13:29:02 +0000 (14:29 +0100)
lxc uses the completionsdir variable from bash-completions.pc to decide
where to install things.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lxc/lxc.mk

index c9838fb22986c25dea2a6a0367ae35e86a94c7bc..c758a15b9dc8334f71ca0be3528b31e6b7cc4fbb 100644 (file)
@@ -17,6 +17,10 @@ LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
        --disable-werror \
        $(if $(BR2_PACKAGE_BASH),,--disable-bash)
 
+ifeq ($(BR2_PACKAGE_BASH_COMPLETION),y)
+LXC_DEPENDENCIES += bash-completion
+endif
+
 ifeq ($(BR2_PACKAGE_GNUTLS),y)
 LXC_CONF_OPTS += --enable-gnutls
 LXC_DEPENDENCIES += gnutls