quota: don't try to strip binaries during installation
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Oct 2014 17:58:25 +0000 (19:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 8 Oct 2014 17:58:25 +0000 (19:58 +0200)
quota strips binaries during installation by default using 'install -s', but
that uses the host strip so doesn't work for cross compilation, and
stripping or not is handled globally in Buildroot during target-finalize, so
disable it here.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/quota/quota.mk

index 5011c0fc2cbc9f41065840426d486ba65c2a3b3c..0e7a2b0d80e9158d944757973a7dcd866156bb33 100644 (file)
@@ -9,6 +9,7 @@ QUOTA_SITE = http://downloads.sourceforge.net/project/linuxquota/quota-tools/$(Q
 QUOTA_DEPENDENCIES = host-gettext
 QUOTA_AUTORECONF = YES
 QUOTA_LICENSE = GPLv2+
+QUOTA_CONF_OPTS = --disable-strip-binaries
 
 QUOTA_CFLAGS = $(TARGET_CFLAGS)
 QUOTA_LDFLAGS = $(TARGET_LDFLAGS)