package/dovecot: Add optional support for icu
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 21 May 2015 07:40:56 +0000 (09:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 16:48:05 +0000 (18:48 +0200)
Optional dependency added to fts plugin since Dovecot 2.2.17:
http://hg.dovecot.org/dovecot-2.2/diff/b179bbd226e5/configure.ac

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dovecot/dovecot.mk

index 3b4f6d138e93a2cf9cfb916d07edb5cea55a491f..58666d03b28958c3d1da91f21f12bb1d83abcc3c 100644 (file)
@@ -40,6 +40,13 @@ else
 DOVECOT_CONF_OPTS += --without-bzlib
 endif
 
+ifeq ($(BR2_PACKAGE_ICU),y)
+DOVECOT_CONF_OPTS += --with-icu
+DOVECOT_DEPENDENCIES += icu
+else
+DOVECOT_CONF_OPTS += --without-icu
+endif
+
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
 DOVECOT_CONF_OPTS += --with-libcap
 DOVECOT_DEPENDENCIES += libcap