Makefile: do not add to targets common dependencies
authorFabio Porcedda <fabio.porcedda@gmail.com>
Fri, 27 Jun 2014 12:15:59 +0000 (14:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 14:43:55 +0000 (16:43 +0200)
Remove the rule that adds common dependencies to every target in the
"TARGETS" variable, because all those targets are packages that use the
package infrastructure or they depend on targets that use the package
infrastructure. The package infrastructure already adds common
dependencies.  Therefore, this rule is useless.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 92030128838ce1663d10aee56749978994db6d4f..89127915c6da0bc2436d04de22fd2976b047ee65 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -421,10 +421,6 @@ $(BUILD_DIR)/buildroot-config/auto.conf: $(BR2_CONFIG)
 
 prepare: $(BUILD_DIR)/buildroot-config/auto.conf
 
-# Add base dependencies to all targets even on those not based on the
-# package framework.
-$(TARGETS): dirs prepare dependencies
-
 world: target-post-image
 
 .PHONY: all world toolchain dirs clean distclean source outputmakefile \