perl-file-slurp: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:53 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Aug 2018 21:40:27 +0000 (23:40 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-file-slurp/Config.in [new file with mode: 0644]
package/perl-file-slurp/perl-file-slurp.hash [new file with mode: 0644]
package/perl-file-slurp/perl-file-slurp.mk [new file with mode: 0644]

index a1c037aedb399967cb49859dec627f9bff6c63f1..8348ce102f0460572bd8c1abe539c655dfc4e4e4 100644 (file)
@@ -488,6 +488,7 @@ F:  package/perl-data-uuid/
 F:     package/perl-date-manip/
 F:     package/perl-dbi/
 F:     package/perl-device-serialport/
+F:     package/perl-file-slurp/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index 23a5628f502deabb9877f2cc3fef4b78fbce0ea0..ba5b0e1699219f63fc1d91ed9e5eb3987c19cb17 100644 (file)
@@ -684,6 +684,7 @@ menu "Perl libraries/modules"
        source "package/perl-encode-detect/Config.in"
        source "package/perl-encode-locale/Config.in"
        source "package/perl-file-listing/Config.in"
+       source "package/perl-file-slurp/Config.in"
        source "package/perl-file-util/Config.in"
        source "package/perl-gd/Config.in"
        source "package/perl-gdgraph/Config.in"
diff --git a/package/perl-file-slurp/Config.in b/package/perl-file-slurp/Config.in
new file mode 100644 (file)
index 0000000..69a8871
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_FILE_SLURP
+       bool "perl-file-slurp"
+       help
+         Simple and Efficient Reading/Writing/Modifying of Complete
+         Files
+
+         https://metacpan.org/release/File-Slurp
diff --git a/package/perl-file-slurp/perl-file-slurp.hash b/package/perl-file-slurp/perl-file-slurp.hash
new file mode 100644 (file)
index 0000000..18f9e65
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    7d584cd15c4f8b9547765eff8c4ef078 File-Slurp-9999.19.tar.gz
+sha256 ce29ebe995097ebd6e9bc03284714cdfa0c46dc94f6b14a56980747ea3253643 File-Slurp-9999.19.tar.gz
+
+# computed by scancpan
+sha256 17e638d011c04b1d39b300c07ccd0c57d7857b9ccdb9fe7abce1b15f0e7b0c20 README
diff --git a/package/perl-file-slurp/perl-file-slurp.mk b/package/perl-file-slurp/perl-file-slurp.mk
new file mode 100644 (file)
index 0000000..32773dd
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# perl-file-slurp
+#
+################################################################################
+
+PERL_FILE_SLURP_VERSION = 9999.19
+PERL_FILE_SLURP_SOURCE = File-Slurp-$(PERL_FILE_SLURP_VERSION).tar.gz
+PERL_FILE_SLURP_SITE = $(BR2_CPAN_MIRROR)/authors/id/U/UR/URI
+PERL_FILE_SLURP_LICENSE = Artistic or GPL-1.0+
+PERL_FILE_SLURP_LICENSE_FILES = README
+
+$(eval $(perl-package))