package/rpm: use external xz library
authorRomain Naour <romain.naour@openwide.fr>
Sun, 18 Jan 2015 19:53:09 +0000 (20:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Feb 2015 22:13:24 +0000 (23:13 +0100)
Internal xz backend is statically linked and need a static
libintl library when BR2_NEEDS_GETTEXT_IF_LOCALE is set.
But for a shared only build, there is no static libintl available
in the sysroot.

Use the external xz library provided by Buildroot instead of
using the internal xz backend.

Fixes:
http://autobuild.buildroot.net/results/2c6/2c61562008418ff58fa3085a3342b0e304923073/

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rpm/rpm.mk

index 68d964afc8e20b9102f22655785ba34fccb7747d..fda10f2248c4b1e2288fa01f782e558340bcdde3 100644 (file)
@@ -46,7 +46,10 @@ endif
 
 # xz payload support needs a toolchain w/ C++
 ifeq ($(BR2_PACKAGE_XZ)$(BR2_INSTALL_LIBSTDCPP),yy)
-RPM_CONF_OPTS += --with-xz
+RPM_DEPENDENCIES += xz
+RPM_CONF_OPTS += --with-xz=external
+else
+RPM_CONF_OPTS += --with-xz=none
 endif
 
 ifeq ($(BR2_PACKAGE_BZIP2),y)