core/pkg-kconfig: don't enforce check for config file when not building
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 13 Jul 2015 10:31:58 +0000 (12:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 08:24:10 +0000 (10:24 +0200)
Currently, this is triggering the error message:
    make randconfig
    make source

Only limit the check to enforce a config file being set to when we are
actually building, like is done in the various kconfig-using packages.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index c86c3408398ca92e3af178db681d92be9afa951a..f708875bca004cf5b0db766261a457d96af0ad06 100644 (file)
@@ -90,9 +90,11 @@ $$($(2)_TARGET_CONFIGURE): $$($(2)_DIR)/.stamp_kconfig_fixup_done
 ifeq ($$($$($(2)_KCONFIG_VAR)),y)
 
 # FOO_KCONFIG_FILE is required
+ifeq ($$(BR_BUILDING),y)
 ifeq ($$($(2)_KCONFIG_FILE),)
 $$(error Internal error: no value specified for $(2)_KCONFIG_FILE)
 endif
+endif
 
 # Configuration editors (menuconfig, ...)
 #