package/pipewire: add xlib_libX11 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 19 Dec 2019 19:28:01 +0000 (20:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 21 Dec 2019 22:10:27 +0000 (23:10 +0100)
xlib_libX11 is an optional dependeny of spa, see:
https://github.com/PipeWire/pipewire/blob/0.2.7/spa/meson.build

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pipewire/pipewire.mk

index aa3fdc489d6efb6a8736734530c4b49a7f8ce8c2..df159c5ef4599b08bf31a968ee251e906dd56c9e 100644 (file)
@@ -27,6 +27,10 @@ ifeq ($(BR2_PACKAGE_SDL2),y)
 PIPEWIRE_DEPENDENCIES += sdl2
 endif
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
+PIPEWIRE_DEPENDENCIES += xlib_libX11
+endif
+
 ifeq ($(BR2_PACKAGE_PIPEWIRE_GSTREAMER),y)
 PIPEWIRE_CONF_OPTS += -Dgstreamer=enabled
 PIPEWIRE_DEPENDENCIES += libglib2 gstreamer1 gst1-plugins-base