package/x11vnc: add dependency on libvncserver
authorMartin Kepplinger <martink@posteo.de>
Sun, 30 Apr 2017 13:05:02 +0000 (15:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Apr 2017 21:02:03 +0000 (23:02 +0200)
x11vnc needs libvncserver, so select it explicitely.

Fixes:

  http://autobuild.buildroot.net/results/34f8045e772b96293cc7d25bd61ac0aa5842824f/

Signed-off-by: Martin Kepplinger <martink@posteo.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11vnc/Config.in
package/x11vnc/x11vnc.mk

index 0909b9aec4c6672f0f04f59f0d25154354976c2d..9e91a11ad1c5b40402a6d755cc9744ba9413aa1d 100644 (file)
@@ -2,6 +2,8 @@ config BR2_PACKAGE_X11VNC
        bool "x11vnc"
        depends on BR2_PACKAGE_XORG7
        depends on BR2_USE_MMU # fork()
+       depends on !BR2_nios2 # libvncserver
+       select BR2_PACKAGE_LIBVNCSERVER
        select BR2_PACKAGE_XLIB_LIBXT
        select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXTST
index 9233b7047aed9f42a212b17628167d9c0f677329..f1f4da21bc350994e5683e58ec2e94970d467a73 100644 (file)
@@ -9,7 +9,7 @@ X11VNC_SITE = $(call github,LibVNC,x11vnc,$(X11VNC_VERSION))
 # sdl support is not used in x11vnc, but host include / library search paths
 # leak in if host has sdl-config
 X11VNC_CONF_OPTS = --without-sdl
-X11VNC_DEPENDENCIES = xlib_libXt xlib_libXext xlib_libXtst
+X11VNC_DEPENDENCIES = xlib_libXt xlib_libXext xlib_libXtst libvncserver
 X11VNC_LICENSE = GPL-2.0+
 X11VNC_LICENSE_FILES = COPYING