sshfs: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:18:59 +0000 (23:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:35:41 +0000 (01:35 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sshfs/Config.in
package/sshfs/sshfs.mk

index 54aa8312b7d63aa0abfaf6a7d18d095f174ecd88..54e92c6f8a8ea10ffe73b5cfc219f5c149df6c13 100644 (file)
@@ -6,7 +6,6 @@ config BR2_PACKAGE_SSHFS
        depends on !BR2_STATIC_LIBS # libfuse
        select BR2_PACKAGE_LIBFUSE
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_OPENSSH
        help
index 1288318903cb217670ba1d7cd03d49dc926e6300..ee96ad67e8c7d2de8186ae8d604bdf552947a5d4 100644 (file)
@@ -10,7 +10,7 @@ SSHFS_LICENSE = GPL-2.0
 SSHFS_LICENSE_FILES = COPYING
 SSHFS_DEPENDENCIES = \
        libglib2 libfuse openssh \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+       $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_ENABLE_LOCALE),,libiconv)
 
 $(eval $(autotools-package))