sngrep: gnutls support also needs libgcrypt
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 Jan 2017 07:17:18 +0000 (20:17 +1300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 Jan 2017 07:21:19 +0000 (20:21 +1300)
The gnutls support in sngrep not only needs gnutls, but also
libgcrypt. So only enable gnutls support when both packages are
available.

Fixes:

  http://autobuild.buildroot.net/results/18fbb5748a6ad66ac6ec8141c3296d2b13fa40ac/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sngrep/sngrep.mk

index b4b91c9af51b01f1e8862a967194ceb5b42677a0..52c8a2da4e0c1eec1568ee8fb9af607558da01a9 100644 (file)
@@ -18,7 +18,8 @@ SNGREP_CONF_OPTS += --disable-unicode
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 SNGREP_DEPENDENCIES += openssl
 SNGREP_CONF_OPTS += --with-openssl --without-gnutls
-else ifeq ($(BR2_PACKAGE_GNUTLS),y)
+# gnutls support also requires libgcrypt
+else ifeq ($(BR2_PACKAGE_GNUTLS)$(BR2_PACKAGE_LIBGCRYPT),yy)
 SNGREP_DEPENDENCIES += gnutls
 SNGREP_CONF_OPTS += --with-gnutls --without-openssl
 else