package/gli: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 10 Apr 2019 17:57:46 +0000 (19:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Apr 2019 16:28:28 +0000 (18:28 +0200)
Needed for Kodi 18.x-compatible version of kodi-screensaver-rsxs.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/gli/Config.in [new file with mode: 0644]
package/gli/gli.hash [new file with mode: 0644]
package/gli/gli.mk [new file with mode: 0644]

index 98d3a1db94595f905c45f614ed06b9817ee2c338..e2ee7cbf697a253aedd3d70c2f72a1e4a5afae45 100644 (file)
@@ -295,6 +295,7 @@ F:  package/freeswitch/
 F:     package/freeswitch-mod-bcg729/
 F:     package/ghostscript/
 F:     package/giflib/
+F:     package/gli/
 F:     package/glmark2/
 F:     package/hdparm/
 F:     package/jsoncpp/
index 5f14a66b3c823bfb8046e1c0c4dec773d0704b27..eed842c67ab2e83a787dc32dfa66db2c963cc68d 100644 (file)
@@ -1657,6 +1657,7 @@ menu "Other"
        source "package/flatcc/Config.in"
        source "package/gconf/Config.in"
        source "package/gflags/Config.in"
+       source "package/gli/Config.in"
        source "package/glibmm/Config.in"
        source "package/glm/Config.in"
        source "package/gmp/Config.in"
diff --git a/package/gli/Config.in b/package/gli/Config.in
new file mode 100644 (file)
index 0000000..da7ce28
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GLI
+       bool "gli"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         OpenGL Image (GLI)
+
+         http://gli.g-truc.net
+
+comment "gli needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/gli/gli.hash b/package/gli/gli.hash
new file mode 100644 (file)
index 0000000..177358a
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 9374f3cf6441dac0154f7e5ae9ad9ae99f4c4a36f8eb6de23f54a1996b9f2769  gli-559cbe1ec38878e182507d331e0780fbae5baf15.tar.gz
+sha256 e26459f62353e631d18379668c82b85f9fd2fd993f2818277e4fce21e957f87a  manual.md
diff --git a/package/gli/gli.mk b/package/gli/gli.mk
new file mode 100644 (file)
index 0000000..6a332d0
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# gli
+#
+################################################################################
+
+GLI_VERSION = 559cbe1ec38878e182507d331e0780fbae5baf15
+GLI_SITE = $(call github,g-truc,gli,$(GLI_VERSION))
+GLI_LICENSE = MIT
+GLI_LICENSE_FILES = manual.md
+
+# GLI is a header-only library, it only makes sense
+# to have it installed into the staging directory.
+GLI_INSTALL_STAGING = YES
+GLI_INSTALL_TARGET = NO
+
+$(eval $(cmake-package))