package/nginx: add support for stream proxy modules
authorMartin Bark <martin@barkynet.com>
Tue, 3 May 2016 09:36:55 +0000 (10:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 May 2016 20:30:05 +0000 (22:30 +0200)
Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nginx/Config.in
package/nginx/nginx.mk

index 0c39a635d83d40abc44accaa781d1d61d8eb0283..f925cc75bc0a68f462ed9aa0a7f3022d8ea0ae3e 100644 (file)
@@ -304,6 +304,49 @@ config BR2_PACKAGE_NGINX_MAIL_SMTP_MODULE
 
 endif #BR2_PACKAGE_NGINX_MAIL
 
+config BR2_PACKAGE_NGINX_STREAM
+       bool "stream proxy modules"
+
+if BR2_PACKAGE_NGINX_STREAM
+
+config BR2_PACKAGE_NGINX_STREAM_SSL_MODULE
+       bool "ngx_stream_ssl_module"
+       select BR2_PACKAGE_OPENSSL
+       help
+         Enable ngx_stream_ssl_module
+
+config BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE
+       bool "ngx_stream_limit_conn_module"
+       default y
+       help
+         Enable ngx_stream_limit_conn_module
+
+config BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE
+       bool "ngx_stream_access_module"
+       default y
+       help
+         Enable ngx_stream_access_module
+
+config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE
+       bool "ngx_stream_upstream_hash_module"
+       default y
+       help
+         Enable ngx_stream_upstream_hash_module
+
+config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_LEAST_CONN_MODULE
+       bool "ngx_stream_upstream_least_conn_module"
+       default y
+       help
+         Enable ngx_stream_upstream_least_conn_module
+
+config BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE
+       bool "ngx_stream_upstream_zone_module"
+       default y
+       help
+         Enable ngx_stream_upstream_zone_module
+
+endif #BR2_PACKAGE_NGINX_STREAM
+
 comment "misc. modules"
 
 config BR2_PACKAGE_NGINX_SELECT_MODULE
index 25fb9a886e90ef531c82bd4660e726fe7dc089b4..7f3b075a733531ae439582ff933fd9f6233ab311 100644 (file)
@@ -207,6 +207,24 @@ NGINX_CONF_OPTS += \
 
 endif # BR2_PACKAGE_NGINX_MAIL
 
+# stream modules
+ifeq ($(BR2_PACKAGE_NGINX_STREAM),y)
+NGINX_CONF_OPTS += --with-stream
+
+ifeq ($(BR2_PACKAGE_NGINX_STREAM_SSL_MODULE),y)
+NGINX_DEPENDENCIES += openssl
+NGINX_CONF_OPTS += --with-stream_ssl_module
+endif
+
+NGINX_CONF_OPTS += \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_LIMIT_CONN_MODULE),,--without-stream_limit_conn_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_ACCESS_MODULE),,--without-stream_access_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_HASH_MODULE),,--without-stream_upstream_hash_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_LEAST_CONN_MODULE),,--without-stream_upstream_least_conn_module) \
+       $(if $(BR2_PACKAGE_NGINX_STREAM_UPSTREAM_ZONE_MODULE),,--without-stream_upstream_zone_module)
+
+endif # BR2_PACKAGE_NGINX_STREAM
+
 define NGINX_DISABLE_WERROR
        $(SED) 's/-Werror//g' -i $(@D)/auto/cc/*
 endef