cryptodev: add new virtual
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 27 Apr 2013 10:09:46 +0000 (10:09 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 5 May 2013 20:59:47 +0000 (22:59 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/cryptodev/Config.in [new file with mode: 0644]
package/cryptodev/cryptodev.mk [new file with mode: 0644]

index 62a97b426595cd8268bcd9ff92bdc08886306e20..3c01ce8d2737cda49a745dd496c20488e09e3388 100644 (file)
@@ -386,6 +386,7 @@ endmenu
 
 menu "Crypto"
 source "package/beecrypt/Config.in"
+source "package/cryptodev/Config.in"
 source "package/gnutls/Config.in"
 source "package/libgcrypt/Config.in"
 source "package/libgpg-error/Config.in"
diff --git a/package/cryptodev/Config.in b/package/cryptodev/Config.in
new file mode 100644 (file)
index 0000000..3f08e9e
--- /dev/null
@@ -0,0 +1,37 @@
+config BR2_PACKAGE_CRYPTODEV
+       bool "cryptodev support"
+       depends on BR2_LINUX_KERNEL
+       help
+         Select the desired cryptodev implementation.
+
+if BR2_PACKAGE_CRYPTODEV
+
+choice
+       prompt "cryptodev variant"
+       default BR2_PACKAGE_CRYPTODEV_LINUX if !BR2_microblaze
+       help
+         Select the cryptodev implementation.
+
+config BR2_PACKAGE_CRYPTODEV_LINUX
+       bool "cryptodev-linux"
+       depends on !BR2_microblaze
+       help
+         Cryptodev-linux is a device that allows access to Linux kernel
+         cryptographic drivers; thus allowing userspace applications
+         to take advantage of hardware accelerators.
+
+         http://cryptodev-linux.org/index.html
+
+config BR2_PACKAGE_OCF_LINUX
+       bool "ocf-linux"
+       help
+         OCF-Linux is a Linux port of the OpenBSD/FreeBSD Cryptographic
+         Framework (OCF). This port aims to bring full asynchronous HW/SW
+         crypto acceleration to the Linux kernel and applications
+         running under Linux.
+
+         http://ocf-linux.sourceforge.net/
+
+endchoice
+
+endif
diff --git a/package/cryptodev/cryptodev.mk b/package/cryptodev/cryptodev.mk
new file mode 100644 (file)
index 0000000..b6f4a42
--- /dev/null
@@ -0,0 +1,24 @@
+#############################################################
+#
+# Virtual cryptodev package
+#
+#############################################################
+
+CRYPTODEV_SOURCE =
+
+ifeq ($(BR2_PACKAGE_CRYPTODEV_LINUX),y)
+CRYPTODEV_DEPENDENCIES += cryptodev-linux
+endif
+
+ifeq ($(BR2_PACKAGE_OCF_LINUX),y)
+CRYPTODEV_DEPENDENCIES += ocf-linux
+endif
+
+ifeq ($(CRYPTODEV_DEPENDENCIES),)
+define CRYPTODEV_CONFIGURE_CMDS
+       echo "No CRYPTODEV implementation defined. Configuration error"
+       exit 1
+endef
+endif
+
+$(eval $(generic-package))