package/mfoc: new package
authorLouis Aussedat <aussedat.louis@gmail.com>
Fri, 20 Dec 2019 18:14:56 +0000 (19:14 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Dec 2019 10:30:16 +0000 (11:30 +0100)
Signed-off-by: Louis Aussedat <aussedat.louis@gmail.com>
[yann.morin.1998@free.fr: fix leading spaces in Config.in]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/mfoc/Config.in [new file with mode: 0644]
package/mfoc/mfoc.hash [new file with mode: 0644]
package/mfoc/mfoc.mk [new file with mode: 0644]

index f2b37e55acb870a87300f1d74b29eeb9e84d20da..d2089e2672ce8e103ec3dc8194f903c72a065f2d 100644 (file)
@@ -1428,6 +1428,7 @@ F:        package/ti-sgx-um/
 N:     Louis Aussedat <aussedat.louis@gmail.com>
 F:     board/friendlyarm/nanopi-neo-plus2/
 F:     configs/friendlyarm_nanopi_neo_plus2_defconfig
+F:     package/mfoc
 F:     package/python-dnspython/
 F:     package/python-future/
 F:     package/python-huepy/
index 247d96831e41fb8145fc3ff42c8999d3cb9d4df3..2bfec097025c883073dca23cbbcf4c1a5c370f97 100644 (file)
@@ -2286,6 +2286,7 @@ menu "System tools"
        source "package/lxc/Config.in"
        source "package/mender/Config.in"
        source "package/mender-grubenv/Config.in"
+       source "package/mfoc/Config.in"
        source "package/monit/Config.in"
        source "package/ncdu/Config.in"
        source "package/netifrc/Config.in"
diff --git a/package/mfoc/Config.in b/package/mfoc/Config.in
new file mode 100644 (file)
index 0000000..1267cf0
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_MFOC
+       bool "mfoc"
+       select BR2_PACKAGE_LIBNFC
+       help
+         Mifare Classic Offline Cracker
+
+         https://github.com/nfc-tools/mfoc
diff --git a/package/mfoc/mfoc.hash b/package/mfoc/mfoc.hash
new file mode 100644 (file)
index 0000000..2358bfd
--- /dev/null
@@ -0,0 +1,3 @@
+# locally computed
+sha256  2dfd8ffa4a8b357807680d190a91c8cf3db54b4211a781edc1108af401dbaad7  mfoc-0.10.7.tar.gz
+sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING
diff --git a/package/mfoc/mfoc.mk b/package/mfoc/mfoc.mk
new file mode 100644 (file)
index 0000000..15105a7
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# mfoc
+#
+################################################################################
+
+MFOC_VERSION = 0.10.7
+MFOC_SITE = $(call github,nfc-tools,mfoc,mfoc-$(MFOC_VERSION))
+MFOC_LICENSE = GPL-2.0
+MFOC_LICENSE_FILES = COPYING
+MFOC_DEPENDENCIES = libnfc
+# Fetching from github, we need to generate the configure script
+MFOC_AUTORECONF = YES
+MFOC_INSTALL_STAGING = YES
+
+# Autoreconf requires an existing m4 directory
+define MFOC_MKDIR_M4
+       mkdir -p $(@D)/m4
+endef
+MFOC_PRE_CONFIGURE_HOOKS += MFOC_MKDIR_M4
+
+$(eval $(autotools-package))