package/Makefile.in: ensure libtool doesn't search host dirs for libraries
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 May 2011 13:23:40 +0000 (15:23 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 May 2011 13:23:40 +0000 (15:23 +0200)
Commit 7e3e8ec040b (CFLAGS/LDFLAGS: don't add -I / -L args for STAGING_DIR)
exposed a lingering libtool problem.

Unless instructed otherwise (using -L) libtool will search its built in
system path for libraries, and use those instead if found. The default
search path is '/usr/lib, /lib, /usr/local/lib', which is no good for
cross compilation.

Fix it by setting the system search path to the empty string, effectively
disabling this feature.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index 7811d51d46df9b1a9624f62cf5e17c506b6cc784..391777ead9180e0638b484470e114ed59383fdb6 100644 (file)
@@ -284,6 +284,7 @@ TARGET_CONFIGURE_ARGS= \
        ac_cv_func_malloc_0_nonnull=yes \
        ac_cv_func_calloc_0_nonnull=yes \
        ac_cv_func_realloc_0_nonnull=yes \
+       lt_cv_sys_lib_search_path_spec="" \
        $(BR2_AC_CV_C_BIGENDIAN)
 
 #######################################################################