package/gloox: new package
authorYair Ben-Avraham <yairba@protonmail.com>
Tue, 19 May 2020 08:26:30 +0000 (08:26 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 28 May 2020 20:26:31 +0000 (22:26 +0200)
gloox is a rock-solid, full-featured Jabber/XMPP client library,
written in clean ANSI C++. It makes writing spec-compliant clients
easy and allows for hassle-free integration of Jabber/XMPP
functionality into existing applications. gloox is released under the
GNU GPLv3. Commercial licensing and support are available.

Signed-off-by: Yair Ben Avraham <yairba@protonmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/gloox/Config.in [new file with mode: 0644]
package/gloox/gloox.hash [new file with mode: 0644]
package/gloox/gloox.mk [new file with mode: 0644]

index e427ab15d4b16c67674c4d20b9f69dd7db72ce9c..1320944186378be1a83aaf893a850a9891cc8c45 100644 (file)
@@ -2633,6 +2633,9 @@ F:        package/python-pyusb/
 N:     Wojciech NiziƄski <niziak@spox.org>
 F:     package/fwup/
 
+N:     Yair Ben Avraham <yairba@protonmail.com>
+F:     package/gloox/
+
 N:     Yann E. MORIN <yann.morin.1998@free.fr>
 F:     board/friendlyarm/nanopi-neo/
 F:     configs/nanopi_neo_defconfig
index c12676d85969ab033417fd7477e05888f3804939..e81f2f6bdb72c09a8e3eb6bfe0513d9a7269d2d3 100644 (file)
@@ -2040,6 +2040,7 @@ menu "Networking applications"
        source "package/freeswitch-mod-bcg729/Config.in"
        source "package/gerbera/Config.in"
        source "package/gesftpserver/Config.in"
+       source "package/gloox/Config.in"
        source "package/glorytun/Config.in"
        source "package/gupnp-tools/Config.in"
        source "package/gutenprint/Config.in"
diff --git a/package/gloox/Config.in b/package/gloox/Config.in
new file mode 100644 (file)
index 0000000..91e9f06
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_GLOOX
+       bool "gloox"
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_MPC
+       help
+         gloox is a portable high-level Jabber/XMPP library for C++. It
+         is fully compliant with the XMPP RFCs, supports all of the
+         XMPP features (including SRV lookups, TLS, SASL, roster
+         management, and privacy lists), and implements several XEPs
+         that make it ideal for writing any kind of Jabber/XMPP client
+         or component.
+
+         https://camaya.net/gloox/
+
+comment "gloox needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/gloox/gloox.hash b/package/gloox/gloox.hash
new file mode 100644 (file)
index 0000000..ee42c07
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  97cb6a0c07e320ffa4a7c66e8ab06b2361086271dc87ed2398befef4e8435f8a  gloox-1.0.23.tar.bz2
+sha256  40a20c41c8dabb8ba61bea983fa8f2f6989e67fac56bb62c2249053807fd26af  LICENSE
diff --git a/package/gloox/gloox.mk b/package/gloox/gloox.mk
new file mode 100644 (file)
index 0000000..46fe4d6
--- /dev/null
@@ -0,0 +1,45 @@
+################################################################################
+#
+# gloox
+#
+################################################################################
+
+GLOOX_VERSION = 1.0.23
+GLOOX_SOURCE = gloox-$(GLOOX_VERSION).tar.bz2
+GLOOX_SITE = https://camaya.net/download
+GLOOX_LICENSE = GPL-3.0 with OpenSSL exception
+GLOOX_LICENSE_FILES = LICENSE
+GLOOX_INSTALL_STAGING = YES
+GLOOX_DEPENDENCIES = mpc
+GLOOX_CONF_OPTS = \
+       --without-libidn \
+       --enable-getaddrinfo
+
+GLOOX_CXXFLAGS = $(TARGET_CXXFLAGS)
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+GLOOX_CXXFLAGS += -O0
+endif
+GLOOX_CONF_ENV += CXXFLAGS="$(GLOOX_CXXFLAGS)"
+
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+GLOOX_CONF_ENV += LIBS=-latomic
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+GLOOX_CONF_OPTS += --with-zlib
+GLOOX_DEPENDENCIES += zlib
+else
+GLOOX_CONF_OPTS += --without-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+GLOOX_CONF_OPTS += --with-openssl --without-gnutls
+GLOOX_DEPENDENCIES += openssl
+else ifeq ($(BR2_PACKAGE_GNUTLS),y)
+GLOOX_CONF_OPTS += --with-gnutls --without-openssl
+GLOOX_DEPENDENCIES += gnutls
+else
+GLOOX_CONF_OPTS += --without-gnutls --without-openssl
+endif
+
+$(eval $(autotools-package))