grep: fix target install and clean
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Jul 2008 10:35:56 +0000 (10:35 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 23 Jul 2008 10:35:56 +0000 (10:35 -0000)
package/grep/grep.mk

index 0e99698e0d8f2d7e20523c02edf0b8ea4ab7e3f7..a7affa57366e92806c388975a998f7b618c8244b 100644 (file)
@@ -58,21 +58,16 @@ $(GNUGREP_DIR)/.configured: $(GNUGREP_DIR)/.unpacked
 $(GNUGREP_DIR)/$(GNUGREP_BINARY): $(GNUGREP_DIR)/.configured
        $(MAKE) -C $(GNUGREP_DIR)
 
-# This stuff is needed to work around GNU make deficiencies
-grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
-       @if [ -L $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) ]; then \
-               rm -f $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY); fi
-       @if [ ! -f $(GNUGREP_DIR)/$(GNUGREP_BINARY) -o $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY) -ot \
-       $(GNUGREP_DIR)/$(GNUGREP_BINARY) ]; then \
-           set -x; \
-           rm -f $(TARGET_DIR)/bin/grep $(TARGET_DIR)/bin/egrep $(TARGET_DIR)/bin/fgrep; \
-           cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
-               $(GNUGREP_DIR)/src/fgrep $(TARGET_DIR)/bin/; fi
+$(TARGET_DIR)/$(GNUGREP_TARGET_BINARY): $(GNUGREP_DIR)/$(GNUGREP_BINARY)
+       for i in egrep fgrep grep; do \
+               $(INSTALL) $(GNUGREP_DIR)/src/$$i $(@D); \
+       done
+       $(STRIPCMD) $(STRIP_STRIP_ALL) $@
 
-grep: uclibc $(GNUGREP_EXTRA_DEPS) grep-target_binary
+grep: uclibc $(GNUGREP_EXTRA_DEPS) $(TARGET_DIR)/$(GNUGREP_TARGET_BINARY)
 
 grep-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUGREP_DIR) uninstall
+       rm -f $(addprefix $(TARGET_DIR)/bin/,egrep fgrep grep)
        -$(MAKE) -C $(GNUGREP_DIR) clean
 
 grep-dirclean: