package/vuejs-router: new package
authorThomas Claveirole <thomas.claveirole@green-communications.fr>
Mon, 2 Aug 2021 15:48:12 +0000 (17:48 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 29 Aug 2021 16:27:10 +0000 (18:27 +0200)
Vue Router is the official router for Vue.js.

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
[Arnout: use comment instead of submenu]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
DEVELOPERS
package/Config.in
package/vuejs-router/Config.in [new file with mode: 0644]
package/vuejs-router/vuejs-router.hash [new file with mode: 0644]
package/vuejs-router/vuejs-router.mk [new file with mode: 0644]

index 31bcd277474803821f2ec0f74a5f93b21481fb39..66c5a6703cb2e0dc14bdb74de1bba51213d95e16 100644 (file)
@@ -2568,6 +2568,7 @@ F:        package/x265/
 N:     Thomas Claveirole <thomas.claveirole@green-communications.fr>
 F:     package/fcgiwrap/
 F:     package/openlayers/
+F:     package/vuejs-router/
 
 N:     Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 F:     docs/manual/
index 2dc105defab2d0a3b9eff6bafae8d3ac034dc2b3..2dbe511de0e6be8ec91287362a2a525f6739b097 100644 (file)
@@ -1639,6 +1639,10 @@ endif
        source "package/openlayers/Config.in"
        source "package/popperjs/Config.in"
        source "package/vuejs/Config.in"
+if BR2_PACKAGE_VUEJS
+comment "External Vue.js plugins"
+       source "package/vuejs-router/Config.in"
+endif
 endmenu
 
 menu "JSON/XML"
diff --git a/package/vuejs-router/Config.in b/package/vuejs-router/Config.in
new file mode 100644 (file)
index 0000000..ac79b3e
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_VUEJS_ROUTER
+       bool "vuejs-router"
+       help
+         The official router for Vue.js.
+
+         http://router.vuejs.org
diff --git a/package/vuejs-router/vuejs-router.hash b/package/vuejs-router/vuejs-router.hash
new file mode 100644 (file)
index 0000000..62b1650
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  d85cb70686cad36a087ad9586f1839c9997f707eb0065445fb1ea3d9218494f6  vue-router-4.0.10.tgz
+sha256  9c0015250f592a09d7787efc07152afcf661fff6bda2554359f6d00987828c02  LICENSE
diff --git a/package/vuejs-router/vuejs-router.mk b/package/vuejs-router/vuejs-router.mk
new file mode 100644 (file)
index 0000000..60e751e
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# vuejs-router
+#
+################################################################################
+
+VUEJS_ROUTER_VERSION = 4.0.10
+VUEJS_ROUTER_SOURCE = vue-router-$(VUEJS_ROUTER_VERSION).tgz
+VUEJS_ROUTER_SITE = https://registry.npmjs.org/vue-router/-
+VUEJS_ROUTER_LICENSE = MIT
+VUEJS_ROUTER_LICENSE_FILES = LICENSE
+
+# Install .prod.js as .js
+define VUEJS_ROUTER_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 644 -D $(@D)/dist/vue-router.global.prod.js \
+               $(TARGET_DIR)/var/www/vue-router.js
+endef
+
+$(eval $(generic-package))