pkg-utils: kconfig helpers: use single iso double quoting
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Mon, 14 Jul 2014 11:50:26 +0000 (13:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 17:18:40 +0000 (19:18 +0200)
The echo statements in the kconfig helpers are currently using double
quotes. For KCONFIG_SET_OPT this is problematic when the value argument
itself contains a double quote (a string value). In this case, the statement
    echo "$(1)=$(2)" >> $(3)
would become:
    echo "FOO="string value"" >> /some/path/.config
resulting in the string
    FOO=string value
in the config file, rather than the properly quoted
    FOO="string value"

The linux package worked around this by escaping the quote characters, but
a prettier solution is to use single quoting in the helpers (or
alternatively use no quoting at all).
A side effect of this change is that a $variable in the key or value would
no longer be interpreted by the shell, removing any unexpected behavior.

This change is only really necessary for KCONFIG_SET_OPT, but for symmetry
reasons the other helpers are updated too.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk
package/pkg-utils.mk

index bd3f2ac293fffd258733f3228f38bcb304ad9ec4..bcd9dc168f6249c466ced8e2a2b1e12d76b31030 100644 (file)
@@ -180,7 +180,7 @@ define LINUX_CONFIGURE_CMDS
        # rebuilt using the linux26-rebuild-with-initramfs target.
        $(if $(BR2_TARGET_ROOTFS_INITRAMFS),
                touch $(BINARIES_DIR)/rootfs.cpio
-               $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.cpio\",$(@D)/.config)
+               $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,"$(BINARIES_DIR)/rootfs.cpio",$(@D)/.config)
                $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0,$(@D)/.config)
                $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_STATIC),,
index e8028644459de90df059c95c88ea10d424824df8..99e1f7644ffc5ccf4c7d3513968bf37a78d70e7a 100644 (file)
@@ -35,17 +35,17 @@ $(eval $(call caseconvert-helper,LOWERCASE,$(join $(addsuffix :,$([TO])),$([FROM
 
 define KCONFIG_ENABLE_OPT # (option, file)
        $(SED) "/\\<$(1)\\>/d" $(2)
-       echo "$(1)=y" >> $(2)
+       echo '$(1)=y' >> $(2)
 endef
 
 define KCONFIG_SET_OPT # (option, value, file)
        $(SED) "/\\<$(1)\\>/d" $(3)
-       echo "$(1)=$(2)" >> $(3)
+       echo '$(1)=$(2)' >> $(3)
 endef
 
 define KCONFIG_DISABLE_OPT # (option, file)
        $(SED) "/\\<$(1)\\>/d" $(2)
-       echo "# $(1) is not set" >> $(2)
+       echo '# $(1) is not set' >> $(2)
 endef
 
 # Helper functions to determine the name of a package and its