package/kodi: Add support for libssh
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 20 Oct 2015 19:42:26 +0000 (21:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 20 Oct 2015 20:03:31 +0000 (22:03 +0200)
This patch depends on http://patchwork.ozlabs.org/patch/512480/
and adds sftp support to the virtual filesystems supported by Kodi.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kodi/Config.in
package/kodi/kodi.mk

index eede24328dcb5c917f52854040dfc852aa5df763..9d3ea6f59141622346f7a55b7f846cb417426ed3 100644 (file)
@@ -218,6 +218,12 @@ config BR2_PACKAGE_KODI_LIBSMBCLIENT
        help
          Enable Samba support
 
+config BR2_PACKAGE_KODI_LIBSSH
+       bool "ssh"
+       select BR2_PACKAGE_LIBSSH
+       help
+         Enable sftp virtual filesystem using libssh.
+
 config BR2_PACKAGE_KODI_LIBTHEORA
        bool "theora"
        select BR2_PACKAGE_LIBTHEORA
index 24c5e5a21cbba70e314d795b7d777b133768771d..46d8650c9a5657a643841ecbfa8fb255337e99d3 100644 (file)
@@ -34,7 +34,6 @@ KODI_CONF_OPTS +=  \
        --disable-openmax \
        --disable-projectm \
        --disable-pulse \
-       --disable-ssh \
        --disable-vdpau \
        --disable-vtbdecoder \
        --enable-optimizations
@@ -172,6 +171,13 @@ else
 KODI_CONF_OPTS += --disable-airplay
 endif
 
+ifeq ($(BR2_PACKAGE_KODI_LIBSSH),y)
+KODI_DEPENDENCIES += libssh
+KODI_CONF_OPTS += --enable-ssh
+else
+KODI_CONF_OPTS += --disable-ssh
+endif
+
 ifeq ($(BR2_PACKAGE_KODI_AVAHI),y)
 KODI_DEPENDENCIES += avahi
 KODI_CONF_OPTS += --enable-avahi