upmpdcli: fix static linking issue
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 31 May 2015 19:40:07 +0000 (21:40 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 May 2015 19:42:07 +0000 (21:42 +0200)
Fixes:
http://autobuild.buildroot.net/results/7ed/7ed85071bc06b4806e90b278a0736ea70c01b456/

Upmpdcli forgets to take the dependencies of libupnpp into consideration,
breaking static linking, so help it.

Libupnpp unfortunately doesn't provide a .pc file, so manually handle its
dependencies here.

The build system doesn't expand LIBS from the configure step, so manually
pass it to make.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/upmpdcli/upmpdcli.mk

index 0be4d912ae3ea450b4afa3e72c3f476889dc02c3..a5c6370fd5ab80d072a76eb88ac28de48ae72b74 100644 (file)
@@ -10,6 +10,18 @@ UPMPDCLI_LICENSE = GPLv2+
 UPMPDCLI_LICENSE_FILES = COPYING
 UPMPDCLI_DEPENDENCIES = libmpdclient libupnpp
 
+ifeq ($(BR2_STATIC_LIBS),y)
+# Upmpdcli forgets to take the dependencies of libupnpp into
+# consideration, breaking static linking, so help it.
+# Libupnpp unfortunately doesn't provide a .pc file, so manually
+# handle the dependencies here.
+# The build system doesn't expand LIBS from the configure step, so
+# manually pass it to make.
+UPMPDCLI_DEPENDENCIES += host-pkgconf
+UPMPDCLI_MAKE_OPTS = \
+       LIBS='$(shell $(PKG_CONFIG_HOST_BINARY) --libs expat libcurl libupnp)'
+endif
+
 # Upmpdcli only runs if user upmpdcli exists
 define UPMPDCLI_USERS
        upmpdcli -1 upmpdcli -1 * - - - Upmpdcli MPD UPnP Renderer Front-End