package/python-backcall: new package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 19 Apr 2019 09:19:28 +0000 (11:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Apr 2019 14:37:10 +0000 (16:37 +0200)
Specifications for callback functions passed in to an API.

https://github.com/takluyver/backcall

No license source files are provided from current version, however
upstream added one:
https://github.com/takluyver/backcall/blob/master/LICENSE

python-backcall is a runtime dependency of python-inotify 7.3.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-backcall/Config.in [new file with mode: 0644]
package/python-backcall/python-backcall.hash [new file with mode: 0644]
package/python-backcall/python-backcall.mk [new file with mode: 0644]

index dae860969c2367866dad0345e02dd09af7f78099..89c5f529ed7e1214503b7a78f8fa5d4391c818ea 100644 (file)
@@ -833,6 +833,7 @@ F:  package/ncmpc/
 F:     package/oniguruma/
 F:     package/oprofile/
 F:     package/pcmanfm/
+F:     package/python-backcall/
 F:     package/rygel/
 F:     package/safeclib/
 F:     package/tinycbor/
index a3ef2748c99b6080059f30f37804fee6ddb872cc..7eb2376d57c818554659e0dafac8b39e5df356f2 100644 (file)
@@ -828,6 +828,7 @@ menu "External python modules"
        source "package/python-autobahn/Config.in"
        source "package/python-automat/Config.in"
        source "package/python-babel/Config.in"
+       source "package/python-backcall/Config.in"
        source "package/python-backports-abc/Config.in"
        source "package/python-backports-shutil-get-terminal-size/Config.in"
        source "package/python-backports-ssl-match-hostname/Config.in"
diff --git a/package/python-backcall/Config.in b/package/python-backcall/Config.in
new file mode 100644 (file)
index 0000000..7b4345c
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_BACKCALL
+       bool "python-backcall"
+       help
+         Specifications for callback functions passed in to an API.
+
+         https://github.com/takluyver/backcall
diff --git a/package/python-backcall/python-backcall.hash b/package/python-backcall/python-backcall.hash
new file mode 100644 (file)
index 0000000..2eccbde
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/backcall/json
+md5    87ce0c7839808e6a3427d57df6a792e7  backcall-0.1.0.tar.gz
+sha256 38ecd85be2c1e78f77fd91700c76e14667dc21e2713b63876c0eb901196e01e4  backcall-0.1.0.tar.gz
diff --git a/package/python-backcall/python-backcall.mk b/package/python-backcall/python-backcall.mk
new file mode 100644 (file)
index 0000000..3f95ea3
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-backcall
+#
+################################################################################
+
+PYTHON_BACKCALL_VERSION = 0.1.0
+PYTHON_BACKCALL_SOURCE = backcall-$(PYTHON_BACKCALL_VERSION).tar.gz
+PYTHON_BACKCALL_SITE = https://files.pythonhosted.org/packages/84/71/c8ca4f5bb1e08401b916c68003acf0a0655df935d74d93bf3f3364b310e0
+PYTHON_BACKCALL_SETUP_TYPE = distutils
+# From https://github.com/takluyver/backcall/blob/master/LICENSE
+PYTHON_BACKCALL_LICENSE = BSD-3-Clause
+
+$(eval $(python-package))