qemu: fix build of target variant
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Oct 2016 21:26:21 +0000 (23:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Oct 2016 21:26:21 +0000 (23:26 +0200)
Similar to what was done in commit
524b6b85595274ca13bd7d01adb61ce2dddd786c for the host variant, this
commit fixes the build of qemu's host variant. Qemu expects that the
cpp it is passed behave like cc: it passes the -c option, which is not
allowed by cpp, but is allowed for cc.

Fix that by overriding CPP when calling configure.

Fixes:

  http://autobuild.buildroot.net/results/0850e80ba62294397b44d8adea197a244a9a8205/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qemu/qemu.mk

index 9815f76cf23855943976c61a171f88435e36f24b..cf23f16a3c19c6ce8ba1953151a697d12df07bfc 100644 (file)
@@ -196,11 +196,14 @@ else
 QEMU_OPTS += --disable-fdt
 endif
 
+# Override CPP, as it expects to be able to call it like it'd
+# call the compiler.
 define QEMU_CONFIGURE_CMDS
        ( cd $(@D);                                     \
                LIBS='$(QEMU_LIBS)'                     \
                $(TARGET_CONFIGURE_OPTS)                \
                $(TARGET_CONFIGURE_ARGS)                \
+               CPP="$(TARGET_CC) -E"                   \
                $(QEMU_VARS)                            \
                ./configure                             \
                        --prefix=/usr                   \